Scrivener not compiling

Scrivener for Mac is hanging up and never finishing a compilation as a manuscript Word. Oddly, I can compile to outline in Word.

I have checked for some of the past problems mentioned in the forum. I took out all of the images. I checked for empty footnotes.

Any other suggestions?

  1. Quit out of Word, and try compiling to Word again. If you are recompiling to the same document target which you have in the meantime opened in word (or maybe even currently have open in word), Word may have a lock on the file.

  2. Try compiling to some other format to see if the problem is specific to compiling to Word. Compile to RTF? Compile to pdf?

Thanks for the ideas.

  1. I tried closing Word, but it had no effect. Still would not compile.
  2. It will compile to PDF, but will not to RTF.
    It will also compile to a Proof format in Word.

Try compiling smaller pieces of the complete manuscript. You may find that a specific document refuses to Compile: use the Edit → Text Tidying → Zap Gremlins command on that document.

Kewms, thank you for the suggestions.

  • I tried compiling just a piece of the manuscript, but the compiler still hung up.
  • I tried the Text Tidying (did not know about that), but the compiler still hangs.

When compiling, are you overwriting a pre-existing file ?
I don’t know if a Mac system has the equivalent of Window’s read only/write protect, but if that is the case, perhaps that is the issue here.

(I am a Windows user, I should probably just shut up, but I couldn’t resist…)

Thank you for the idea, Vincent.
I did compile once to Word, and everything went fine. A few days later after editing and adding to the manuscript, I tried to compile again. The compiler stops about half way and hangs there.
I tried deleting the first Word file and closing Word, but that does not help. Scrivener still cannot compile.

What if you compile to a brand new file (new first ever name, different location) ?
(Your answer, to me, now points even more toward what I said earlier… You say it worked the first time, but not after opening and/or editing the file in Word. Perhaps Word somehow locked it.)

I tried a new file name and new location, but Scrivener still froze on the compiling.
I added more to the Scrivener file after the first compile, so I suspect there is something that I added that offends Word.

We could try a Zoom session:

Zoom me