Scrivener not reacting

I think I didn’t really use Scrivener since I finished my master’s thesis on it some months ago. But now I wanted to use it again and it always hangs at opening a project, be it an existing or a new one. I have already tried reinstalling Scrivener, though it already was the newest version before. I hope, there is a way I can get Scrivener to work again, since I like it very much and would love to revive my creativity with its help.
I use OS X Mavericks 10.9.4 on a 2010 Macbook Pro.
Thanks in advance for any hints at what else I could try.

It depends on what type of hang you are experiencing. Is it the sort where when you restart the software you get a window about it having crashed last time, with the choice to submit a report—or is it the type where the pizza wheel just starts spinning and never stops until you force quit the software?

For both types: reset your preference files. Let me know if you need instructions on how to do so.

For the crash reporter type: since it has been a while, I’d double-check your applications and make sure they are all up to date, particularly those that might insert special functions into other programs, like contextual menu features (like for instance, how Evernote lets you capture selected text when right-clicking anywhere on the Mac), or those tools that modify or enhance how the system works, such as text expansion tools, file dialogue enhancements, Growl—all that kind of stuff. The Mac is very interconnected, and an old out of date program can sometimes bring down other software that interacts with it.

A good way to check for that without having to go through every little thing is to reboot with the shift key held down. That will disable all third-party add-ons, extensions and inhibit programs from automatically starting up (Dropbox, etc.). With a clean environment, see if Scrivener loads, if it does, then reboot normally, test again, and if it crashes again chances are high that you’ve got something out of date that is in your user start-up list.

With a perpetual pizza wheel of death type: I’d check reset the caches. Use a tool like Maintenance to do that and reboot the computer. These can sometimes get gummed up, and if Scrivener is calling on a font that has a corrupted cache it will just hang will trying to load the project.

Thanks a lot for your quick answer, AmberV!
Since I’ve got the pizza wheel type and sometimes a nothing-happening-at-all-after-the-Open-file-window-closes-type, I tried resetting the caches and checking and deleting corrupt .plist-files first. I used Onyx for both tasks, as I already had that on my computer. Unfortunately that didn’t help. I then also tried the shift-reboot, but had the same problem with opening Scrivener-Projects there. Same thing after uninstalling Growl which has been deactivated on my computer anyway.
I will now try Maintenance, too. Just in case Onyx missed something.

No. Even after using Maintenance and de- and reinstalling Scrivener once more, I still have the same problem. What’s interesting though: When I tried to open an existing project in the newly installed Scrivener, it said, that this project was already open and whether I wanted to make a new copy of it and open that one instead.

Have you tried moving the Preference files out of the library and onto the desktop, so the program won’t find them, and the restarting Scrivener? It will create new preference files automatically.

You may have done this already, but it’s not mentioned in the thread, so I thought I’d bring it up.

Mr X

Maintenance is a subset of Onyx, the former is just a stripped down single-purpose tool made by the same developer. One question, when you mentioned earlier you could not create a new project, did you test by making a plain Blank project, or were you always selecting from a template? Try with Blank, if you have not already.

That just means the project was not successfully closed, if this is all on one computer and there is no file sharing going on. Since Scrivener is crashing repeatedly, I’m not surprised there was an occasion where it couldn’t cleanly close a project.

One last thing: be sure to leave the Console open while doing all of this, and report any messages that appear related.

Thanks, Mr X! I have now tried the thing with the preferences, but it didn’t change anything.
And, AmberV, thanks again. When I tried creating a new project, it always was a blank one. But thanks to you I now used the Console for the first time in my life and saw that com.apple.ShareKitHelper and com.apple.BKAgentService are constantly crashing:

27.09.14 00:00:45,622 xpcd[168]: Info.plist does not contain an XPCService dictionary: /System/Library/Frameworks/Security.framework/XPCServices/SecurityAgent.xpc 27.09.14 00:00:45,732 xpcd[168]: com.apple.ShareKitHelper[7199]: registration request failed: (0x11, 0x0) Could not obtain real path to the container root (~/Library/Containers/com.apple.ShareKitHelper/Data): The operation couldn’t be completed. No such file or directory 27.09.14 00:00:46,397 com.apple.launchd[1]: (com.apple.ShareKitHelper[7199]) Job appears to have crashed: Illegal instruction: 4 27.09.14 00:00:46,397 com.apple.launchd[1]: (com.apple.ShareKitHelper) Throttling respawn: Will start in 10 seconds 27.09.14 00:00:46,634 ReportCrash[7194]: Saved crash report for com.apple.ShareKitHelper[7199] version 1.0 (185.2) to /Library/Logs/DiagnosticReports/com.apple.ShareKitHelper_2014-09-27-000046_Macbook.crash 27.09.14 00:00:48,024 xpcd[168]: Info.plist does not contain an XPCService dictionary: /System/Library/Frameworks/Security.framework/XPCServices/SecurityAgent.xpc 27.09.14 00:00:48,097 xpcd[168]: com.apple.BKAgentService[7200]: registration request failed: (0x11, 0x0) Could not obtain real path to the container root (~/Library/Containers/com.apple.BKAgentService/Data): The operation couldn’t be completed. No such file or directory 27.09.14 00:00:48,640 com.apple.launchd[1]: (com.apple.BKAgentService[7200]) Job appears to have crashed: Illegal instruction: 4 27.09.14 00:00:48,640 com.apple.launchd[1]: (com.apple.BKAgentService) Throttling respawn: Will start in 10 seconds 27.09.14 00:00:48,809 ReportCrash[7194]: Saved crash report for com.apple.BKAgentService[7200] version 1.0.1 (158) to /Library/Logs/DiagnosticReports/com.apple.BKAgentService_2014-09-27-000048_Macbook.crash
So I thought, maybe that’s where the actual problem lies and Scrivener might just somehow be affected by this. But until now I don’t really understand, how that would be or just what the two files are for and how I could repair them. Do you have an idea? :question:

Oh, and there are reports on four of Scrivener’s crashes of this last week. They’re very long, but I thought I’d post the first part of one of them:

[code]Date/Time: 2014-09-21 09:30:14 +0200
OS Version: 10.9.4 (Build 13E28)
Architecture: x86_64
Report Version: 18

Command: Scrivener
Path: /Applications/Scrivener.app/Contents/MacOS/Scrivener
Version: 2.5 (2.5)
Parent: launchd [160]

PID: 730
Event: hang
Duration: 3.13s
Steps: 32 (100ms sampling interval)

Hardware model: MacBookPro7,1
Active cpus: 2
Fan speed: 1999 rpm

Free pages: 237400 pages (-5175)
Pageins: 171 pages
Pageouts: 0 pages
Swapins: 0 pages
Swapouts: 0 pages

Process: Scrivener [730]
Path: /Applications/Scrivener.app/Contents/MacOS/Scrivener
Architecture: i386
Parent: launchd [160]
UID: 502
Task size: 16266 pages (+1)
CPU Time: 0.005s

Thread 0xf300 priority 45
32 ??? (Scrivener + 6869) [0x2ad5]
32 NSApplicationMain + 1165 (AppKit) [0x96647ff8]
32 -[NSApplication run] + 727 (AppKit) [0x9665f15c]
32 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 119 (AppKit) [0x9666c870]
32 _DPSNextEvent + 1602 (AppKit) [0x9666d349]
32 _BlockUntilNextEventMatchingListInModeWithFilter + 92 (HIToolbox) [0x952ad6bd]
32 ReceiveNextEventCommon + 163 (HIToolbox) [0x952ad777]
32 RunCurrentEventLoopInMode + 259 (HIToolbox) [0x952adb5d]
32 CFRunLoopRunInMode + 123 (CoreFoundation) [0x9101c84b]
32 CFRunLoopRunSpecific + 394 (CoreFoundation) [0x9101c9ea]
32 __CFRunLoopRun + 1006 (CoreFoundation) [0x9101d04e]
32 __CFRunLoopDoBlocks + 361 (CoreFoundation) [0x9101d809]
32 CFRUNLOOP_IS_CALLING_OUT_TO_A_BLOCK + 16 (CoreFoundation) [0x9102ca00]
32 __80-[NSDocumentController openDocumentWithContentsOfURL:display:completionHandler:]_block_invoke_3 + 356 (AppKit) [0x96b5ecfd]
32 -[NSDocumentController _openDocumentWithContentsOfURL:usingProcedure:] + 555 (AppKit) [0x96b5e1a4]
32 __80-[NSDocumentController openDocumentWithContentsOfURL:display:completionHandler:]_block_invoke_4 + 647 (AppKit) [0x96b5efa7]
32 __80-[NSDocumentController openDocumentWithContentsOfURL:display:completionHandler:]_block_invoke878 + 282 (AppKit) [0x96b5f6f3]
32 __80-[NSDocumentController openDocumentWithContentsOfURL:display:completionHandler:]_block_invoke896 + 230 (AppKit) [0x96b5fc02]
32 ??? (Scrivener + 14467) [0x4883]
32 ??? (Scrivener + 1405874) [0x1583b2]
32 ??? (Scrivener + 1409224) [0x1590c8]
32 -[NSWindowController window] + 121 (AppKit) [0x968fb96b]
32 -[NSWindowController _windowDidLoad] + 517 (AppKit) [0x969162e8]
32 ??? (Scrivener + 1402515) [0x157693]
32 +[NSSharingService sharingServiceNamed:] + 72 (AppKit) [0x9690e0dc]
32 +[SHKSharingService sharingServiceNamed:] + 210 (ShareKit) [0xdb5e7fa]
32 -[SHKSharingController serviceFromProvider:serviceIdentifier:] + 312 (ShareKit) [0xdb53246]
32 -[SHKHelperMessage sendOnConnection:async:reply:] + 254 (ShareKit) [0xdb60950]
32 dispatch_semaphore_wait + 37 (libdispatch.dylib) [0x99bddf1f]
32 semaphore_wait_trap + 10 (libsystem_kernel.dylib) [0x9b009fb6]
*32 semaphore_wait_continue + 0 (mach_kernel) [0xffffff800023b570]

Thread 0xf312 DispatchQueue 2707188396 priority 49
32 _dispatch_mgr_thread + 52 (libdispatch.dylib) [0x99bdb532]
32 kevent64 + 10 (libsystem_kernel.dylib) [0x9b00f992]
*32 ??? (mach_kernel + 3959520) [0xffffff80005c6ae0]

Thread 0xf335 priority 47 cpu time 0.005s
32 thread_start + 34 (libsystem_pthread.dylib) [0x9ad1ecf2]
32 _pthread_start + 130 (libsystem_pthread.dylib) [0x9ad19485]
32 _pthread_body + 144 (libsystem_pthread.dylib) [0x9ad195fb]
32 _NSEventThread + 283 (AppKit) [0x96816b88]
32 CFRunLoopRunInMode + 123 (CoreFoundation) [0x9101c84b]
32 CFRunLoopRunSpecific + 394 (CoreFoundation) [0x9101c9ea]
32 __CFRunLoopRun + 1393 (CoreFoundation) [0x9101d1d1]
32 __CFRunLoopServiceMachPort + 169 (CoreFoundation) [0x9101dbf9]
32 mach_msg_trap + 10 (libsystem_kernel.dylib) [0x9b009f7a]
*32 ipc_mqueue_receive_continue + 0 (mach_kernel) [0xffffff80002167d0]

Thread 0xf537 priority 54
32 thread_start + 34 (libsystem_pthread.dylib) [0x9ad1ecf2]
32 _pthread_start + 130 (libsystem_pthread.dylib) [0x9ad19485]
32 _pthread_body + 144 (libsystem_pthread.dylib) [0x9ad195fb]
32 startIOThread(void*) + 159 (CoreVideo) [0x97cd1180]
32 CVDisplayLink::runIOThread() + 936 (CoreVideo) [0x97cd1540]
32 pthread_cond_wait$UNIX2003 + 71 (libsystem_pthread.dylib) [0x9ad1dbd9]
32 __psynch_cvwait + 10 (libsystem_kernel.dylib) [0x9b00e7ca]
*32 psynch_cvcontinue + 0 (pthread) [0xffffff7f80b99940]

Thread 0x10287 priority 0-47
32 start_wqthread + 30 (libsystem_pthread.dylib) [0x9ad1ecce]
32 __workq_kernreturn + 10 (libsystem_kernel.dylib) [0x9b00f046]
*32 wq_unpark_continue + 0 (pthread) [0xffffff7f80b976ae]

Binary Images:
0x1000 - 0x351ff7 com.literatureandlatte.scrivener2 2.5 (2.5) <80BE1744-42BD-30BF-820B-CBE3335A138A> /Applications/Scrivener.app/Contents/MacOS/Scrivener
0xdb50000 - 0xdb91fff com.apple.ShareKit 1.0 (185.2) /System/Library/PrivateFrameworks/ShareKit.framework/Versions/A/ShareKit
0x90fa7000 - 0x911a9fff com.apple.CoreFoundation 6.9 (855.17) /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation
0x95282000 - 0x955f7ff9 com.apple.HIToolbox 2.1.1 <392738F0-322F-3C80-BEF7-138AFB124C35> /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/HIToolbox.framework/Versions/A/HIToolbox
0x96645000 - 0x97263ff3 com.apple.AppKit 6.9 (1265.21) <1D31697B-6F33-3239-BACE-5D1361B1F79A> /System/Library/Frameworks/AppKit.framework/Versions/C/AppKit
0x97ccf000 - 0x97cf6fff com.apple.CoreVideo 1.8 (117.2) /System/Library/Frameworks/CoreVideo.framework/Versions/A/CoreVideo
0x99bd8000 - 0x99bf0ffd libdispatch.dylib (339.92.1) <7E7A88BF-74B3-363B-B534-6F757DF2DDE3> /usr/lib/system/libdispatch.dylib
0x9ad18000 - 0x9ad1fffb libsystem_pthread.dylib (53.1.4) <8B1B7B84-1B5D-32A8-AC0D-1E689E5C8A4C> /usr/lib/system/libsystem_pthread.dylib
0x9aff7000 - 0x9b014ff4 libsystem_kernel.dylib (2422.110.17) /usr/lib/system/libsystem_kernel.dylib
*0xffffff7f80b94000 - 0xffffff7f80b9bfff com.apple.kec.pthread 1.0 (1) <882075E6-12C4-3225-8750-928715183739> /System/Library/Extensions/pthread.kext/Contents/MacOS/pthread
*0xffffff8000200000 - 0xffffff80007a864a mach_kernel (2422.110.17) /mach_kernel
[/code]
I can only see that it does mention “ShareKit” a few times … :blush:

If it were me I would be considering a full reinstall of Mavericks. Remember you don’t lose content like you do with Windows, so it should be relatively painless. Backup first though.

ShareKit is a part of the Mac, I think it’s for the newer Twitter/Facebook stuff they have now, but I could be wrong about that. At any rate, if it is indeed having issues (which it appears to be) it may be the cause of the problem. Mac software is very interconnected, as you’ve probably gathered by now. One old version of a plug-in or something of that nature can make a mess all over the place.

A question, and a bit of a shot in the dark, to be fair: are you using the Mac App Store version? If so, try downloading the trial version from our main website, and see if you get the same problem there. The trial version will unlock into the full version if it detects a MAS receipt, so you could actually go on using that forever if it works.

You could also give the public beta a shot. That does fix a few known crashers.

Problem solved!
When installing Scrivener’s public beta and reinstalling Mavericks didn’t help either, I dared to look closer at what the recurring crash report about ShareKitHelper actually said. It was looking for a file or directory that didn’t exist. So I created an empty folder by that name, the crash reports ended and Scrivener now works again. :smiley:
Thanks for all your thoughts and help! And long live console! :wink:

Congratulations. Really well done. A very interesting solution too.

I’m having, based on what you describe, a very similar if not an identical problem when I try to create a new Scrivener project, whether blank or based on a standard Scrivener template.

Scrivener in the crash report appears to be reaching a dispatch thread limit and hangs just like you describe. This just started happening yesterday (10/9/2014)

[code]Dispatch Thread Soft Limit Reached: 64 (too many dispatch threads blocked in synchronous operations)

Thread 0x81e1 priority 47
16 ??? (Scrivener + 6869) [0x2ad5][/code]

I’ve looked through the very long list associated with the Scrivener thread and I’m not finding a directory listed so that I can check to see if it is similar to how you fixed your issue.

Bibigirl, where did you find the clue of a directory?

Thank you!

I just accidentally found your question, since I didn’t look at this thread for a while now … as it was solved for me … :wink:
So, the code you quoted is what console says about Scrivener, right? For me, when I opened console it showed an issue that seemed to have nothing to do with Scrivener. That was the one in my earliest code-quote. ShareKitHelper would crash and then restart every 10 seconds, so every 10 seconds there would be a new crash report in console. When I opened one of them (In console you might have to click “show protocolls” or something like that and then it shows a list where you can find those reports. They seem scary, but there’s actually some text in them that a human being can read.) it said: Sandbox creation failed: Could not obtain real path to the container root (~/Library/Containers/com.apple.ShareKitHelper/Data): The operation couldn’t be completed. No such file or directory
I then created the empty directory with that same path which solved my problem.
Your problem sounds a bit different to me, but I still hope this will help you!
Good luck!