Scrivener Not Working?

I’m running into a bit of an issue with getting Scrivener to work. My friend has Scrivener, and I really liked the way that it looked, so I thought I’d give it a shot, and download the free trial for Windows before deciding to buy it. However, I can’t seem to get it to work.

I’ve tried restarting my computer. I’ve tried deleting the file I downloaded, and redownloading a new one. Nothing seems to work.

When I click on the Scrivener.exe installer, it acts as if it’s trying to load, and then nothing happens. Nothing opens, or shows that it’s trying to. I don’t even get any error messages. When I open Windows Task Manager and go to Process, I can see Scrivener there, but it’s not actually open. Does anyone have any suggestions as to how I might fix this issue?

I’d check for any programs running that might be preventing it running, security software or the like. You may need to temporarily disable that to run the installer, and I’d check re-enabling it that it allows Scrivener to launch and run normally without interruption. For file conversions, Scrivener uses VeryDoc’s Doc2Any tool, and occasionally that or a component of that has triggered antivirus software, which can cause problems from the program not launching at all to it hanging when trying to compile. The files are not malicious, but you’ll need to manually white-list them in the antivirus software if you’re running into that issue.

MimeticMouton, thanks for the response!

Unfortunately, disabling any security programs or software I have running doesn’t seem to allow Scrivener to load. I’m not sure what sort of issue I’m running into. I don’t get any error messages, I don’t any indications. I don’t get anything at all. It acts as though it’s trying to load, but then nothing happens. I’ll sit with the program attempting to open for five minutes or more, and nothing seems to happen.

What version of Windows are you using?

Do you have User Account Control (UAC) turned on, so that you need to right-click the installer and run it as Administrator? If you have a non-admin user and you’re trying to install it you might have some permissions issues on some of the paths.

When you downloaded the program, did you right-click it, select Properties, and uncheck “This file came from another computer”?

Do you have enough free space in the default drive location and TEMP folders where the installation files will be extracted?

Scrivener does not require admin rights, at least on WIndows 7. I have it installed on my work computer and I’m not an administrator.

I’m not saying Scrivener does. I have seen problems in the past on Windows systems for all sorts of installers getting hung up on UAC.

Work environments often use the business/enterprise SKUs and can set a lot of the security-related settings via Group Policy, which can change the experience from the typical home/consumer SKUs. It’s not always possible to directly compare the two.

So sorry for the late reply, guys! I haven’t been on my laptop the past couple of days, so I didn’t see all the responses. Thanks for that!

The version of Windows that I’m using is 7. Everything is up to date, and I do have admin rights to my computer. I booted my computer up in safe mode, and I was able to actually get the program to install. However, when back in normal mode, I can’t get the program to open. I disabled my firewall and ran it as an administrator, but that didn’t seem to do anything, either. Again, it acts like it’s trying to load, but nothing happens.

I do have enough free space, but I did not try unblocking the program under Properties.

If you can get it to install and run in safe mode, but not in regular mode, you’ve got some software running that is interfering. You’ll need to use the System Configuration tool in Windows to disable all of your startup software, then work your way through the list turning one on at a time until you find the one that is blocking Scrivener.

If you don’t know how to use the tool, this might help:
http://social.technet.microsoft.com/wiki/contents/articles/758.disable-and-enable-windows-7-startup-programs.aspx