Scrivener opens 1000 words below cursor

In the past couple of weeks I have noticed an odd but consistent behavior that I never saw before. It might have been going on longer but it’s only now that I’ve been stuck on the same chapter that I took notice.

When I launch Scrivener and it loads the last open project, the particular document I was working on is in focus, but at a location about 1000 words below the cursor location. The cursor location is retained - all I have to do is press an arrow key to make the screen jump to it - but consistently the section of the document that appears on first opening Scrivener is a few pages below the cursor. I just tried this 10 different times in different documents in the same project, and 9 of 10 times I got the same error. (In the anomalous 10th, the second in the series of trials, the line containing the cursor appeared in the middle of the window as one would expect.)

My style is set to Courier with a typewriter-like width of 6 inches per line, self-built but very similar to the novel template. So as to fit more words on the screen I have spacing set to 1.5x in both standard and full-screen. Happy to reinstall Scrivener or mess with config files if people think that’s the solution.

Without checking in my version of Scrivener…

I think it opens each document at the last scroll position that document was open with. So perhaps if you read on past the cursor position in those documents, it will open to where you finished reading, not to where the cursor is?

Just a thought, I may be mistaken. Play around with it and see.

Nope, it’s not that - I stop writing and I close the document. When I reopen, it’s 1000 words lower.