Scrivener project opens on iOS -- but not Mac!

My project opens fine on iOS, but on the Mac I get the error message:

I am certain Dropbox was long updated before opening it on the Mac, and vice versa.
I looked in Package Contents and all I see are three folders: files, Mobile and Settings.
I can close and open the project on the iPad, but still can’t open it on the Mac.
I’ve put in a lot of work on the iPad without touching the Mac, so the Mac backup is very outdated.
It has been syncing fine otherwise for months and I have the latest versions of Scrivener.

Is there a way to make the project open on the Mac, since it’s still okay in iOS?

I got exactly the same error message yesterday and cannot open my project on my macbook. No answer yet on my post, but I am hoping for a solution as I spent a great deal of time on my project and hate the idea of having to go back to a backup from a week ago. :cry:

What version of Scrivener for Mac are you using? The two most recent Scrivener for Mac releases (2.9 and 3.03) do not have a “.scrivproj” file in their formats. Seems like Scrivener on your Mac is mistakenly thinking that the lack of a .scrivproj file is a sign that the project is too old, when in fact, it’s too new!

That’s interesting! My versions are the latest ones. So do you know of a way to solve this? Thanks.

I don’t know why your version (which version is it?) thinks it needs a file that hasn’t been part of the format for quite a long time now. I’d definitely send an email to support with all the relevant info (scriv version#, Mac OS version, ios version), and a .zip compressed copy of the project (if it’s not too big) for them to examine.

Will do, thanks.

The “missing scrivproj file” error, in this context, is usually a sign of incomplete synchronization.

From the iOS version’s Project screen, tap the Edit button, select the project, and then tap the ‘Share’ icon at the bottom. (It looks like a box with an arrow coming out of it.) That will allow you to create a ZIP archive and email it to yourself. Which won’t solve the underlying problem, but will at least let you get the project off the device.

For the underlying issue, go here: … os-syncing

And here: … g-with-ios


Thank you. Not sure I understand this, since the project is not on the device, it’s in dropbox. It works fine when using Scrivener on iOS. Will sending it to myself make it readable on Scrivener for Mac? Is there any tweak I can do to the package contents to make it work on the mac? Thanks!

As with all things related to Dropbox and so-called “cloud” services, the way they work is by keeping individual devices up to date in a stand-alone fashion, so that if you go offline you do not lose access to your work. Your project is stored on the iOS device. You could plug it into your Mac with a USB cable and drag it out of iTunes (which would be another way of getting the copy to your Mac). So that’s the idea here, to get that copy that is working fine off of iOS and onto the Mac, since the Dropbox managed copy seems to be out of sorts.

Once you have the same version of the project on both devices, you can replace the copy in Dropbox from the Mac, let it upload, and now they should in theory all be on the same page again.

There may be, but it’s very difficult to say without a comprehensive look at what exists in the Mac’s Dropbox folder. Generally it would be easier to just copy the project to the Mac as it should be, as described above, rather than try and tinker with a copy that sync hasn’t managed correctly for whatever reason.

I guess way of thinking about it would be, if you put a copy of a file on a thumbdrive and try to copy it to another computer, but find the copy on the thumbdrive is incomplete or damaged—you could try and repair it with a bunch of technical tools for doing so, but it will probably be easier to go back and try again, using the original copy that works fine, to do so.

Thanks, Amber. Unfortunately, this happened again, so I saved a working copy onto my ipad, got it over to my computer, renamed it and put it in dropbox. It still won’t open. Any other things I can try? Works fine on the ipad… Thank you.

It seems there is a major misunderstanding here of how these things work.

The project you have on your iPad is always stored on your iPad. If you, in the project view, put it in the part named Dropbox it will also be uploaded/downloaded to/from the Dropbox server when you tap the syncing icon (or answer yes if it asks if you want to sync).
The project you have on your Mac is always stored on your Mac’s hard drive. If you have the Dropbox app installed and running and if you save the project in the Dropbox folder, it will also be uploaded/downloaded to/from the Dropbox server.

For all this to work you must wait for the iPad to sync everything with the Dropbox server before leaving the app on your iPad. You have to wait until the syncing is done. And likewise on the Mac. You have to check in Finder that the project got the green tickmark saying that all its content has been synced with the Dropbox server. When that is done, simply open the project on your Mac (File -> Open). When you are done writing on your Mac you have to wait again for everything to be synced back to the Dropbox server before closing your Mac.

Always remember that there are three computers involved: your Mac, your iPad and between them the Dropbox server. All three must have enough time to communicate with each other before you open or close anything.

Well, I don’t know if there is that severe a misunderstanding—if what 2albion means by getting it over to the computer is using one of the methods I described a couple of posts back, to get the working copy off of the iPad without Dropbox, then yes what they describe makes good sense and is exactly what I would recommend in this scenario:

  1. You send a copy from the iPad to the Mac somehow (AirDrop, iTunes Wifi, USB cable, third-party file manager, whatever).
  2. You try to open the project fresh off of the iPad on the Mac.

This procedure avoids any potential complications that may arise from Dropbox usage, it is the cleanest and simplest way to work in fact, in that it involves no external complexity. So if a project does not open after copying it directly off of the iPad—that indicates there is a problem with the project, not the process (though naturally processes in the past might ultimately be the culprit in the project’s current state—we at least eliminate process as a present-tense factor, which is valuable).

I’d need a little more information than that, to provide any further advice, sorry. It works best to describe all of the error messages you get, the things you see happening on the screen, etc.

One thing I would suggest regardless of the symptoms is to right-click on the project in Finder and “Show package contents”. You should see these folders: Files, Settings and Mobile (there may be more but they are not crucial). You should see one, and only one, .scrivx file. If you see missing folders or many conflict copies of the .scrivx file, then this project needs repair, and is only opening on iOS out of fortune.

Lastly, when you say this happened again, I think that’s a good sign that you should carefully evaluate your procedures—take notes on the actions you take for a while, both in how you use the software and how you sync. This is not a normal cause and effect you’ve encountered. Projects do not typically spontaneously stop working. If it happens once, then maybe something very unfortunate happened like a bad transmission over Dropbox. But if it happens twice? Well, I’d start looking in to what I’m doing at that point, and simplifying my procedure over time as much as I can, noting what seems to work better and what doesnt.

And if you are coming up against a bug, these notes will be valuable in communicating to others how to find it, too.

I guess the next post will tell. Some of the things the OP wrote made me suspect that maybe there is a misunderstanding of the concept ”cloud storage”. Some seems to think that the cloud is like an external HD, not a remote copy of your own HD.

Thanks for your thoughts and suggestions. I do understand how dropbox works. Since I had a similar syncing problem once before (probably my own fault) and am now fairly terrified of losing my work, I am extremely careful about waiting for dropbox to sync. I am certain dropbox was completely synced from my iPad to dropboxfor a full day before I opened it on the Mac and had the problem, so syncing was not the issue in this case.

The project is now in five places: in Dropbox, on my iPad in both the dropbox folder and the On My iPad folder, and on my Mac in both the Dropbox folder and outside the Dropbox folder. All of these open fine on my iPad. None of them open on the Mac.

And yes, I did send the project (zipped, of course) from On My iPad to the Mac without using Dropbox. No luck. I’ve also deleted the project in dropbox, duplicated the project in On My iPad, renamed it, and moved to Dropbox and sent it to the Mac. No luck. It still opens on the iPad and not on the Mac.

The Package Contents are good: Files, Icons, Mobile, QuickLook, Settings, Snapshots and my one scrivx file.

The symptoms are that I can open Scrivener on the Mac, but when open this particular project I see the loading window, the blue progress bar goes all the way across, then Scrivener vanishes from the screen and the Apple bug report screen shows up. I’ve sent these all in. When I reopen Scrivener, I get Scrivener’s own bug report which I also send in.

Sadly, I just completed a major rewrite using only the iPad, so the inability to open it on the Mac is a rather big problem. I know that Dropbox keeps previous version history, but as I recall it sees the .scriv file as a folder so it can’t be restored easily. Anything else I can do? Thanks.

Okay, it may not be a problem with the syncing or project structure itself in that case—no problem with being cautious about those aspects still, but it would be extremely unlikely for a sync problem or conflict of some sort to cause this kind of result you describe. If this progress bar is on a window related to rebuilding the index or in general syncing of changes from mobile, it could be running into some formatting or an image that it doesn’t like that is causing a crash.

Is this a project you could provide to L&L support for testing purposes? If we cannot open it either, and get the same crash, then it will super easy to find where the problem is—and whether it is a bug or piece of content that needs fixing. If that’s fine, send in the .zip you created from your iPad, and make a note of this URL thread so they can connect you with me.

If not, I can walk you through some of the debugging steps I would take to isolate the content causing the hang.

Yeah I think you could probably still dig into the project files themselves using a web browser, but I wouldn’t recommend it. Knowing which of the hundreds of little RTF and TXT files to restore, and to what date, is something that I would consider an absolutely last ditch measure. And I don’t think we’re even close to that point yet.

What I would try first, if you just want a quick solution without figuring out the problem, is to create a new blank project and use the File ▸ Import ▸ Scrivener Project… menu command, selecting the unzipped copy fresh from the iPad. That may very well run into the same crash if it is content related, but it’s worth a shot. That is a good general purpose way to “reset” a project’s internal plumbing while keeping much of the content intact (well, all of the content-content, but you may lose some settings and unused metadata).

I’d be happy to send you a copy of my project. To which address?

I did try to Import the project that works on the iPad and received this error message: MOBILE FILES NEED SYNCING. “COOPER’S WAR 9.scriv” has been changed in the mobile version of Scrivener. Please open the project in the current version of Scrivener to merge changes before trying to import it into the current project.

One possible clue: in my project, I have customized the Script Elements (which includes what happens when I press Tab or Paragraph), but when I use them on the iPad those Tab/Paragraph suddenly stop working correctly, then do, then don’t. I haven’t seen a pattern. Also, fonts change from Courier to Courier New to Courier Prime. Is it possible that syncing repeatedly from Mac to iPad screws these up?

Thank you.

Either the Mac or iOS support address on this page is fine.

Ah ha, okay. I’ve never actually tried to import a project with pending iOS changes before, but that makes perfect sense. The only safe way to merge those edits is do so within the project itself before importing, and the only practical way of doing that is to change the project your importing—which rather defeats the purpose of having a passive import option.

I’d have to check my notes on the scriptwriting issues you mention, but those are familiar to me as bugs we’ve already taken note of to fix for the next iOS release. I wouldn’t think they are related to this, given the different domains in which they operate. iOS basically just reads script settings, it does not set them—as you know, you can’t design formats on the go, you can only use them. So there would be no reason for the Mac version to be “reading” any settings from iOS (there are no iOS settings), and thus no opportunity for there be a jam created in the settings.

Thanks, I got it. The good news is that I got the project working easily enough! Simply follow the checklist from this knowledge base article on the original project, and you should be good to go. Note I only needed to trash the “ui.plist” file, not the “ui-common.xml” file, so you can leave the latter alone. You will need to apply some settings to the project again after doing this.

Thank you so much. This worked perfectly and I am working on my project on my computer again.

Glad to hear it!