Scrivener Running But Not Displaying Onscreen

Hi there,

I’ve looked, but not found a solution to my problem. What’s happening is Scrivener is not opening my Scrivener file or displaying onscreen. It is, however, showing as a running process in Task Manager.

Here are some details and background:

OS: Windows 10
App: Scrivener Version: 1.9.8.0 - 12 Jun 2018
Devices: Dell laptop + ipad
Other: I’ve installed Scrivener on my ipad and synced the two instances (laptop and ipad) with Dropbox.

Yesterday I set up Dropbox to host my Scrivener file. Long story short, the standard setup worked fine. I could access and open the .scrivx file from my laptop and from my ipad. Changes made to the file from either device (laptop/ipad) saved and synced and were visible when reopened with either device. Hooray, the world was fine and all was well.

Later in the afternoon, I opened the .scrivx file on my ipad at home and left it open while I went to a shop. I suspected there would not be wifi there (I was right), which is why I opened the file before I left home and why I left it open as I drove to the shop. While at the shop, I wrote and edited the .scrivx on the ipad. I could not save or sync the file, because no wifi.

When I got home and back on wifi, before I synced the ipad, I noticed there were now two .scrivx files in the dropbox\apps\scrivener\MyNovel.scriv directory: the normal .scrivx, and a new one with a lot of letters and numbers and the word conflicted in the file name. Before syncing from the ipad, I tried to open the normal .scrivx with my laptop. That’s when the problem described up top occurred. Scrivener is a running process in Task Manager, but not opening onscreen. At this point, I synced the ipad (the .scrivx file has and remains accessible as normal on my ipad), deleted the “conflicting” .scrivx file, and tried to open the normal file again with my laptop. No luck.

I am able to open local (same HD) backup copies of my .scrivx from elsewhere on my laptop just fine. I’ve done it with three different .scrivx files. The only file that will not open is the one saved to dropbox\apps\scrivener\MyNovel.scriv. I’ve rebooted multiple times and cleared the menu in Recent Projects and searched online for a fix. No love. Help?

Thanks in advance for your time.

Edit: I’ve been trying different compatibility settings as described in he FAQ. When “Run this program in compatibility mode for:” is unchecked or checked for Windows 8, I get the same response as described at the top of the message. When I check the box and select Windows 7 and try to open the file, Scrivener opens a window that says the file already seems to already be in use, or that the project didn’t close properly last time it was used, and I am given options to Continue, Make a Copy, or Cancel. This happens whether the Dropbox process is running or not. To date, I’ve chosen Cancel.

Hi Elraymundo,

Welcome to the forums.

Unfortunately, I don’t have any specific guidance for your particular issue, but in your post you’ve listed Windows and App: Scrivener 3. That can’t be right, as there is no Windows Scrivener 3.

You are using either Win Scrivener v1.x.x or the Win Scrivener 2.9.x beta.

If the former, please edit your post to show which Windows version you have.

If the latter, you should ask a mod to move this to the Beta forum: https://www.literatureandlatte.com/forum/viewforum.php?f=57

That will help with getting this resolved.

HTH,
Jim

Well, that was a colossal goof. :slight_smile: Thanks for pointing that out. I’m not sure how I got that wrong, but I edited the main post with the correct info. I’m running Version: 1.9.8.0 - 12 Jun 2018.

Hey, thanks for the clarification.

Upon rereading, it seems like something you did or something in the timing confused the syncing process and caused a conflict, but from what you’ve posted, I can’t see anything obvious jumping out as a mistake. One thing you should do, is always be sure that you’ve closed and synced on Device 1 before moving to Device 2. So, for example:

  1. On the Laptop: Write. When done, close Scrivener. Confirm that DropBox is done syncing.
  2. On the iPad: Launch Scrivener. Sync. Write. When done, Sync. Close Scrivener.
  3. On the Laptop: Confirm that DropBox is done syncing. Launch Scrivener. Write. When done, close Scrivener. Confirm that DropBox is done syncing.
  4. Go to #2.

If you are habitual and faithful in the above, you shouldn’t see any other conflicts.

But to address your problem now, if you can open the project on the iPad, that’s very good news, as it indicates no corruption in your project files. The laptop version of Scrivener has a setting that erroneously still thinks you are using it on the iPad, but if you’re not, then it’s safe to open it.

Based on that, I recommend you take the following steps:

On the iPad, export your project as a zipped file, just to be on the safe side. Project screen > Edit > Select the project > Share (on the bottom, square icon with the up arrow). Tell Scrivener where to send the zipped file. You can email it to yourself or place it on a cloud service. That way you have a backup from the iPad in case things go sideways on the laptop.

Then, on the laptop, when you get that window from scrivener, choose Continue. Hopefully it opens and all looks good. But you’ve got a backup from the iPad just in case.

If the project looks good, then try making a small change on the laptop, close and sync, then confirm that it still looks good on the iPad. If so, then you’re golden.

Give it a try and let us know!

Jim

Hi, Jim,

Thanks for taking the time to respond. I followed your instructions below, but still no love.

I clicked Continue (with Compatibility Mode set to Window 7, the only option of three I tried that got a Scrivener window to open) and alas, nothing opened at all. (Although Scrivener shows as a running process in Task Manager). I tried again with Compatibility Mode unchecked and got the same result. So no dice.

What I’m going to try now this:

  1. Delete the existing files and folders from Dropbox. (I have a backup elsewhere.)
  2. Sync the ipad.
  3. Unzip the project I emailed to myself into the Dropbox folder.
  4. Try and open the Dropbox file from Scrivener/laptop.

If that works, I’ll sync the ipad and test it there as well.

Step One

  1. I synced the project on my ipad.
  2. I closed Scrivener on the ipad and shut down the ipad.
  3. I created a temp folder on my laptop’s Desktop and unzipped the saved copy of the project into the temp folder.
  4. I tried to open the project file in the temp folder, but I got the same “The file appears to be in use, Continue, Copy, Cancel” message.
  5. I clicked Continue. Scrivener runs, but it does not open onscreen. It seems to use a lot of CPU and memory, too. +/- 25% of CPU and 100 - 150MB of RAM. I wonder if it’s churning, trying to open the file, and getting stuck.

I have Scrivener installed on only two devices. With the ipad turned off, the only device left is the laptop, which is the same device throwing the error. I think the next thing I’ll try will be to delete the Dropbox copy and see if that breaks the startup hang chain. If that doesn’t work, the only thing I can think of is to uninstall/reinstall Scrivener. Unless there is something i am missing? I’ll wait a while to see if anyone has suggestions of feedback before I do these next steps.

Just to confirm: On Windows, you can open other unrelated projects and you can open backups of the problem project, correct?

Yes, you’ve got it.

Thanks fully, the issue is resolved now.

Here’s what I did:

  1. Opened the zipped backup into a new folder on my Desktop.
  2. Uninstalled Scrivener.
  3. Said bad words while trying to find my serial number for the reinstall.
  4. Reinstalled Scrivener.
  5. Opened the project.
  6. A small window popped up that said Scrivener was not responding.
  7. A second window opened saying Scrivener was backing up the project. (I have no idea where it backed up to. It must have a default location, because it didn’t ask me where I wanted it.)
  8. A third window opened saying it was syncing and did I want synced files saved to another folder (or something like that). I said yes.
  9. Scrivener opened the file (hooray!), but there was an icon in the left side of the binder (where the files are) that was new to me – a yellow triangle with an exclamation mark next to the word “Conflicts.” There were two versions of the same file in the Binder. “Running File” (the correct version) and “Running File (Text Conflict).” I have no idea what this second one is.
  10. I closed Scrivener and rebooted and reopened Scrivener and the project. This time when it asked synced files I said no. The project opened as normal and the “Conflict” files were gone. Everything is looking and working as normal. I tested by making changes to one file from the laptop and the ipad and the laptop again, and both devices could see the edits.

Thanks again for your help. It was much appreciated! I might have a couple of details wrong in my write up above, but i think the gist is pretty close to true. Have a good one!

Excellent news, glad to hear this had a happy ending. :smiley: