Scrivener running very slowly

I have been using Scrivener for over a year and have liked using it and it has worked very well. Recently, however, it has started to run very very slowly. Over 30 seconds to type one letter. I checked the Activity Monitor and it says that Scrivener is using 100% CPU almost all of the time it is open. The rest of my computer seems to be running fine.

I have a G4 Macbook 1.83 ghz intel core 2 duo with 512 MB Ram running OS 10.4.8. The file I am working on is text only, no pictures, and is only 6MB.

To solve the problem I have done regular upkeep on my computer - repairing permissions, etc - , thrown out the Scrivener preferences and restarted Scrivener, and upgraded to Scrivener 1.5 from Scrivener 1.1.1. Nothing has helped. I have checked the forums and tried all the solutions that are applicable and still it runs at a snail’s pace. I have also tried to delete unnecessary parts of my manuscript but it takes so long I am unable to delete them.

I would appreciate help with this problem. Any ideas?

Thank you

Something that might help analyse the problem: In Activity Monitor, select Scrivener in the list, and while it is pegged at 100%, click the “Sample Process” button. That will take a few seconds. Once you have that you can save that file out and send it to support. This perhaps will help isolate what is using up all of your CPU like that.

Yes, try what Amber says and send it to me at support AT literatureandlatte DOT com. Also, where is it running slowly? That is, in what circumstances? Are you using Edit Scrivenings? I ask because there is a known bug there in that Edit Scrivenings can slow down when there is lots of text (something I’m optimising for 2.0). Or is it in full screen? If in the latter, try going to Preferences and choosing to hide the main window during full screen mode (Full Screen preferences).

Also be sure that you have no other services running that might be interfering with Scrivener during typing.

Is there any reason you haven’t updated to 10.4.11, incidentally?

All the best,
Keith

Thanks for your quick reply.

I have sent you the “Sample Process” document by email.

I am in the process of updating to 10.4.11 right now.

If truth be told, the computer I am talking about and Scrivener are used by my wife. I am the the de-facto IT guy for the family, which can be time-consuming and annoying so sometimes I am not fully up to date. My wife is in the middle of writing something important and Scrivener bogged down so now I am trying to troubleshoot it. Thanks for your help.

I have this happen to me once every couple of weeks (10.4.11). My unscientific impression is that it’s somehow connected to browser use; although using the browser is usually no problem. I almost always Edit Scrivenings mode in full screen mode. Once Scrivener slows down, even when I close the browser it doesn’t return to normal. A restart always corrects this bug for me… until next time.

A restart of Scrivener, or of the entire operating system?

Entire machine. Even a reboot of the finder won’t do it, although I wouldn’t really expect it to.

I’ve wondered whether it might be related to the fact that I rarely restart my machine, putting it to sleep and waking it day after day, week after week - but again can’t see why that should cause such a slowdown only in Scrivener…

How much memory is Scrivener using when running slow, and how much does it use when you first load your project? Use the Activity Monitor in Applications/Utilities and check the RSize and VSize.

I will do this next time it happens… thanks.

I have a somewhat similar problem. I’ve a branty new computer (imac running 10.5.6) with lots of memory (4MB), but for some strange reason Scrivener (1.50) can be tediously slow. I’ve posted in graphics into the text so perhaps that’s the issue. It happens in and out of Edit Scrivenings.

Donncha

I’m surprised you can even get the system booted up! :wink:

Seriously though, it is difficult to analyse your problem with the data you have provided. Is it slow when you click on items in the Binder? Is it slow when you are typing in the editor?

It’s typing in the editor only …s…l…o…w… it is. I deleted the graphics and the problem disappeared.

That’s interesting… mine slows down in the same way, but I have no graphics in the document(s) I’m editing, and only a few .jpgs in the project. The whole project runs 9.5 MB, but I can’t imagine that effects it because, as I understand it, Scrivener uses only the files you’re working on at any one time.

You are correct, total project size should have no impact on performance unless you are running edit scrivenings on the entire thing. The three known variables which cause editor typing slowdown are:

  1. Using full-screen and having the main window visible at once
  2. Running third-party key tracking software in the background, like spell checkers and keyloggers
  3. Leopard users running on old PPC hardware

Have any of you tried logging out of your account and then back in while holding the shift key down? This will disable all background processes from starting up, ensuring you are running the OS with as clean a slate as possible and eliminating most of #2 (stuff installed at the system level might still be running, but this is much less common).

Hmm… would keystroke software, such as iKey, fall under category number two?

scriptsoftware.com/ikey/

If so, wouldn’t it cause the problem all the time rather than intermittently?

I’m not sure, that is why I recommend logging in with the shift key held down in order to ascertain potential conflicts. If the performance issues disappear, then you know it is something on your login list and you can narrow that down by running them one at a time manually.