Scrivener seems a "ghost application"

OMG, today I just couldn’t use Scrivener. I mean, it WOULD open but in a strange way. Didn’t seem to load anything (like the initial message), all the menus were gray out so I couldn’t open, import or DO ANYTHING! I am literally at the end of a huge work !! Then I read the forum and saw that there could be a font problem. I went to FontBook I clicked on the duplicates… (though I use Font Explorer mostly), but nothing changed.I also cleaned the font caches from the program “Main Menu”… still the same. My only possibility was to do a SAFE REBOOT. Only AFTR THAT, Scrivener worked but obviously NOBODY can work with a Mac Osx (system 10.6.4) WITHOUT extensions!
So now, after a normal restart the same thing is happenning AGAIN. Scrivener SEEMS to open but nothing happens and you cannot even quit it, but force it! Cannot work… Gosh…
I really don’t know where to start from and some help would be really appreciated. :cry:

Are you sure it’s installed properly?

ducks rotten tomatoes Just checking. :slight_smile:

I deleted it and installed it again. And was able to use it properly, but ONLY after the safe reboot. Now it acts like before… I have no idea of what to do now… Is there any “console” message or something I can give you to clear this out?

Yes, some console messages might help. If you don’t know where this is, navigate to Applications using the Finder, and look for a folder called Utilities. Within this folder you should find an application called Every application on the system can report errors and warnings to the system logs, which this application monitors. To make things easier on yourself, you can type in “Scrivener” in the search tool at the top to filter the list. Try launching Scrivener and then copy and paste whatever comes up from that point forward into a message here.

One thing that is interesting is that you reported that it launches when booting into safe mode. There is something else you could try, and that is logging in with safe mode. No need to reboot. Just log out of your account, and then log back in while holding down the shift key. This will skip the ordinary process of loading your background applications, if you have any configured. See if you can run Scrivener that way. If you can, then it’s likely an application that you are running, not a deeper problem. To check and see what is automatically loading when you log in, visit the “Login Items” tab, in the Accounts preference pane for you system. That should give you a clue of what might be interfering with Scrivener.

Before saying anything else, THANKS for helping me!
This is what I get using Console and searching for Scrivener:
30/08/10 23.07.32[117] ([0x0-0x2c02c].com.literatureandlatte.scrivener[470]) Exited: Terminated
30/08/10 23.38.05[123] ([0x0-0x27027].com.literatureandlatte.scrivener[390]) Exited: Terminated
30/08/10 23.40.45[123] ([0x0-0x2e02e].com.literatureandlatte.scrivener[535]) Exited: Terminated
30/08/10 23.41.12[123] ([0x0-0x2f02f].com.literatureandlatte.scrivener[544]) Exited: Terminated
30/08/10 23.51.07[123] ([0x0-0x35035].com.literatureandlatte.scrivener[623]) Exited: Terminated
31/08/10 00.16.09[123] ([0x0-0x38038].com.literatureandlatte.scrivener[807]) Exited: Terminated

Mmmm, just went to my account, took of some apps opening at log in, but I couldn’t really understand the “shift” thing while loggin in. Anyway, I restarted again retyping my password. In the end, though, nothing happened. Again Scrivener just opens and does nothing! :cry: I hope you’ll be able to find the problem from my console data!

The console output isn’t all that helpful this time around.

When you say you “uninstalled”, then “reinstalled” scrivener and then it worked, can you describe how you did this?

Dear Amber & Jasen,

I’ve tried several times logging out and deleting various apps from the log in items. At the moment SCRIVENER OPENS WITHOUT ANY PROBLEM! :smiley: (Well, I guess I’ll have to decide which apps are my priority now! 8)

Thank you VERY MUCH for your help.

Okay, that’s good news! If disabling login items had not worked, then it would have indicated a deeper problem, likely in the operating system itself, and that is no fun. When you reboot in safe mode it also inhibits the login items list. I should have explained that a bit better, though at this point it is irrelevant as you’ve already identified one of these apps is the problem, and using the shift-key trick won’t tell you which, only that one is messing things up. For future reference though, you have to hold down the shift key as soon as you press Enter on your password. So you type in your user name (or select it from the list) and then your password, press Enter and hold down the shift key until the login process is complete. If you have auto-login enable (no password), then you’ll need to do that as soon as you type in or select your account name.

And yes, unfortunately the console messages are not very helpful. I was hoping that perhaps another application would be referenced, but it looks like you’ll have to continue selectively loading things until it breaks to figure out which one.

Had you installed some new, auto-loading application just before this ghosting started to happen. If so, look to that to be the culprit.

Whatever you find, please do let AmberV/Keith/the forum know what it was that caused the problem.