Scrivener should be started from its installed location - what?

I have multiple Scrivener projects that I work and I go back and forth between them a lot. Si I made shortcuts for each of the projects, but get this when I launch them.


Runtime location: “C:\Program Files\Scrivener3”
Installed location: “C:\Users\xxxx\My Stuff\Fiction\Scars of Youth 2021\Scars of Youth - 5th.scriv”

Scrivener should be started from its installed location. If Scrivener isn’t running from its installed location, you will not be able to update Scrivener and your registration may not be recognized. Please, run Scrivener from its installed location, or uninstall and reinstall Scrivener to avoid getting this message.

This confuses me greatly. Why? Well, since ancient times people have been opening docs by double-clicking the doc file. Pretty much every other program in the history of everything will let you open docs this way. Why can’t I do it with Scrivener?

If anyone knows of a way to open Scrivener projects directly, I’d greatly appreciate it if you could teach me how.

Thanks.

If I understand correctly, you’re somehow creating a Windows shortcut set to specify what program should open your project. That shouldn’t be necessary; Windows already knows how to open the .scrivx file inside the .scriv folder; just point a shortcut to the .scrivx file; when you click on it, Windows should know where the default application (Scrivener) is and launch it for you.

1 Like

No, that’s not quite right. For example, when I want to open this file:

“C:\Users\shane\My Stuff\Fiction\Scars of Youth 2021\Scars of Youth - 5th.scriv\Scars of Youth - 5th.scrivx”

I double click the “Scars of Youth - 5th.scrivx” file and get that error message. I get the same message if I use a shortcut to that file as well. I have to use the main app shortcut (“C:\Program Files\Scrivener3\Scrivener.exe”) for it to not spit out that error. Which means that if I want to open another project other than the last one Scrivener used, I have to open Scrivener to the last used project, then manually open the project I want to work on.

I’m pretty good with computers (been using them since 1982 and I was in IT for 17 years). I’ve been around the block so-to-speak and I’ve never used an app that did this.

Didn’t Scrivener 2 used to work this way?

Odd. No, this is an unusual issue that I’ve not seen before (personally or on the forums). Maybe there’s a lingering registry entry that points to the wrong location, such as from downloading and installing it on a separate occasion? Does Windows list multiple instances of it for un-installing? Can you search the registry for scrivener.exe?

I’m pretty much at the limit of my advice for what to look for with that, so good luck!

You need a thorough uninstall of Scrivener, possibly requiring a 3rd party uninstaller. Then download and reinstall Scrivener.

Just to this - you don’t have to open the last project - in the starting screen you should have this button:
image
So just run Scrivener, and then click this to browse for the needed project.

Afraid I can’t fix the issue with the error message though.

Although - can you r-click on the scrivx file, pick Open With and make it change/choose another app, and re-select the correct Scrivener from the list - maybe just this will reset whatever went wrong with the application-to-extension assignment?

Yeah, I used to see this error back in the Windows Scriv 3 beta days. I’m so sorry, but I do not remember what I did to get rid of it. :pouting_cat:

As was already mentioned, it’s possible an uninstall/install might help. Be sure to save your options if you decide to take this step. File > Options > Manage > Save Options to file. Then after the install, do File > Options > Manage > Load Options from file.

I’m sure you already know this, but an alternative way to launch specific projects is Windows key > right click on the Scrivener icon > choose a recent or pinned project. I’ve moved away from shortcuts entirely and do it this way.

If I remember what I did to stop the error I’ll come back and let you know.

Best,
Jim

Yeah, I’ll do this. Turn it off and on again, right? Should have done that first.

Thanks.

Yay! It worked. I rebooted for good measure. Thanks.

2 Likes