Scrivener shuts down on me (impossible to open)

HEEEELP, I can not open the Scrivener application anymore.
Each time it tells me that another copy of the project is open on the computer. No matter what I do (save a copy or continue) when I try to open the file Scrivener shuts down on me.
What can I do; I have like 500 pages that I can not access

What version of Scrivener do you have, and with which version of Mac OS?

Some people have this symptom when running an out-of-date version under Big Sur. If that’s you, you can download Scrivener 3.2.2, our Big Sur compatibility update, here: literatureandlatte.com/scrivener/download

Katherine

Firstly, have you just upgraded to Big Sur, and if so have you upgraded to Scrivener 3.2.2? If yes to the former and no to the latter, go to the website, download the latest version and install it.

Secondly, if it says a copy is open on another computer—and you’re sure that is not the case—that means that for some reason the user.lock file in the project was not deleted when it was closed. Without knowing more, it’s hard to know how that has happened, but it’s the last thing that happens when a project is closed down and it can happen, for instance, if you’re saving to a cloud service like Dropbox and are a fraction too quick to close your computer before it’s been removed from the cloud server. Anyway:

  1. Navigate to "your-project.scriv’ in Finder
  2. Right click (Ctrl-click) on it and from the menu choose “Show Package Contents”
  3. The window will show a folder named “Files” click on that
  4. amongst other things you should find a file named “user.lock” … delete that (absolutely do not do anything else!)
  5. Close the Finder window

Only do that when you are sure it isn’t open on another computer! But having done that, the project should open fine as long as you have sorted out the first problem.

Hope that helps. :slight_smile:

Mark

EDIT; Katherine got there first. Follow her instructions and only follow mine if you still get the “Copy open …” alert.

Quit opening that project, and just open the Scrivener application itself from the application folder. Then see if Scriv is auto-opening some other copy of your project by some chance, and close that if so.

Wow, thanks so much Kathrine and Mark. I downloaded the new version and could reopen my project.
Thanks again
Agata


"Quit opening that project, and just open the Scrivener application itself from the application folder. Then see if Scriv is auto-opening some other copy of your project by some chance, and close that if so.
[/quote]
"

How do I close the other projects. Indeed, I have several copies open but I don’t know how to close them. If I right click on them, here goes again the same message (already open).

[quote]
Thanks

You can open Scrivener without any projects by holding the Shift key when the program starts.

Once Scrivener is open, you can close any open projects with the File → Close Project command.

Katherine

Sorry Katherine, I tried several times holding the shift key but it didn’t work. All previously open projects are still listed when I right click on he icon and if I go to File, the Close the project option is not available. When I open one of such projects, I can access the Close the project command but then the Project is still listed when I right click and when I try to open it it tells me that a copy is already open :frowning:

That list doesn’t show you open projects. It shows a list of recently opened projects.
If you get the “already open” warning it means that you never closed that project last time you used it. This could happen if Scrivener crashed, if you save your projects on an external media and removed that before closing Scrivener, accessing your project from more than one Mac using a cloud service and not closing the project on the other computer, etc.

You are confusing different things.

Indeed, this appeared after my computer crashed. Whatever the reason, I still don’t know what to do to avoid having that Open project message every time I try to access my project. The solution described by Katherine doesn’t work, as explained in my previous post. How can I avoid having those annoying messages???
Thanks

Have you tried doing what I suggested about removing the “user.lock” file in any projects that shaw that message?

Mark

As lunk explained, the menu you see when you right-click on the Scrivener icon has nothing to do with which projects will or will not open. It’s just a list of recently used projects.

To open Scrivener without any projects, hold the Shift key when the program starts. Left click on the Scrivener icon, or open Scrivener from the Applications folder, rather than the Dock.

Then, use the Open Project menu – not the Recent Projects menu – to locate and open the project you want. Do you still see the error?

Katherine