Scrivener slow/non-responsive on Windows 7

Hi all, my PC is running Windows 7 home premium on an intel i5. I purchased Scrivener and can run the latest version on my laptop (which has Windows 10 pro running on an intel i3) just fine. However, on my desktop, Scrivener seems to move at an extremely slow pace, bordering on non-responsive, all at the “new project” screen! Going into the resource manager reveals that Scrivener is consuming 24-25% of the CPU’s total processing power and has the CPU running at 109% frequency. Is there a fix for this issue?

Turn off your antivirus temporarily, and run Scrivener with administrator rights. See if that helps. If it does, then you’ll know the problem is not with Scrivener.

Thanks- I’ve tried doing that, but I still get the same problem. CPU usage is the same. I am working with the most current version, version 1.9.8. I’ve tried 1.9.7, but I get the same result.

I’ve tried launching ScrivenerLog.bat as an administrator. Attached is my log. The hangup seems to revolve around the line “Warning: QSettings: RegEnumValue failed:”

Scrivener-20180727-172037155.txt (306 KB)

That’s not something I’ve encountered before. I suggest you contact LL directly at: https://www.literatureandlatte.com/contact-us

Hello,

I found a LL Knowledge Article that fixed the Windows 7 issue for me: scrivener.tenderapp.com/help/kb … y-settings. It requires changing the Compatibility Mode for running the Scrivener.EXE. I also checked the ‘Run as Administrator’ checkbox.

This may also fix other ‘Not responding’ issues for other Windows OS versions.

Hope that helps,
Znorker

Thanks Znorker. I’ve been having trouble getting Scrivener to open since the last Java 8 update. I tried reinstalling the update but that didn’t work, and finally I used your link to figure out how to set Scrivener to work in comparability mode and it is opening again now. The strange thing is that I set the comparability for Windows 7 and that’s what I’m running.