Scrivener software won't install

I downloaded the free trial version of Scrivener earlier this morning but I can’t get it to install.
It downloaded fully (83.4MB) but when I click on the installer nothing happens.
Any advice or suggestions?
I’m using Firefox, Windows XP on a desktop.

In case it helps anyone else who encounters the same problem, I was able to install the software by sending the installer to a thumb drive. It opened when I clicked on it from there (I have no idea why, or even why I thought of trying that, but anyway it worked).

Hm, it could have been some sort of permissions issue with the original download location, or a different default behaviour I suppose. I’m glad you got it working!

Same thing happened to me - when running installer, only thing happening was an empty dialog box opening up. Ran separately and in combinations of administrator, compatibility mode. The thing that worked was to copy to another drive (my C: drive), and it worked. The download folder has no special permissions, and I install from it all the time. ? Anyway, if you’re having same issue, copy to another hard drive (or flash drive) and try it then.

Scapple Trial version will not install on Windows 10.
Tried Administrator and ordinary Open method.
Tried pasting from Downloads folder to C Drive. Unsuccessful.