Scrivener suddenly decided it's incompatible

This morning I did some work in Scrivener on my laptop, and everything worked as normal.

This evening, when I went to try to open it, the icon in Finder has the crossed-out-circle forbidden sign over it, and the application refuses to open. I haven’t done any updates or other system activity today, and nothing else has changed in my setup. I tried restarting the machine, but still the same. It’s as if it thinks the version I have (2.6) is incompatible with the OS (10.9.5). :frowning:

The only thing I can think of is that I upgraded my desktop iMac to Yosemite over the weekend - but I can’t see how that would affect whether my laptop can even open Scrivener, especially as it worked perfectly well this morning.

Addendum: When I try to open a .scriv file directly, Finder tells me: “You can’t open the application Scrivener because it may be damaged or incomplete.”

This is a relatively common problem. Automatic updating can sometimes damage the application. Notes on what to do are provided in a notice box at the top of our support page (basically: just reinstall from a fresh download).

I did the Yosemite upgrade and did not experience this issue, so I don’t think it is related. However, I have experienced the same symptoms before, even though I never new why it happened. Reinstalling Scrivener fixed it for me.

Thanks, Amber. At least the downtime forced me to finally try out Aeon Timeline, which turned out to be super-useful. So :smiley: