Scrivener text jumps around when I try to select a word

I’m in scrivenings mode and I see a word I want to change, so I roll the cursor to hover over the target word and then double click.
In response all the text on the page jumps around and selects a different word entirely.

Solutions?

I’ve tried unticking the Tools > Options > Typewriter scrolling in new projects. Didnt make any difference.

Maybe I need a way to deactivate typewriter scrolling in this particular project?

All help gratefully received.

Format | Options | Typewriter Scrolling.

(Or Ctrl+G, Ctrl+T)

Perfect. Thanks so much.

I wonder why they didnt put all the typewriter controls on the same tab.