Scrivener unable to save my project

I just updated everything this morning (I was having problems getting Scrivener to open), and I’m now getting error messages when Scrivener autosaves on one project. I currently have three open, but wasn’t having any problems with the two smaller ones.

The message reads:
"The following errors occurred while saving your project
Could not save project document ‘30 (Citadel Battle)’
Failed saving text for document with id: 163
Error: 'Could not open RTF file for writing.
File: ‘C:/Users/Owner/Dropbox/Apps/Scrivener/Out of the Twilight.scriv/files/docs/163.rtf’
Error:‘Access is denied’

To avoid losing your latest changes, make sure you have enough space and write access on your storage device.
You can create a copy of your project into another location using the menu File > saveAs
You might also try to Compile and Save to RTF or DOC format to avoid losing your latest changes."

I saved a copy to my dropbox the last time I got this (a paragraph ago), and also saved a zipped copy to my desktop.

That reads to me like the update has altered the file permissions on that file ro make it “Read only”.



Okay, so how do I fix it?

I’m sorry, I’m a Mac user, so don’t know how you set permissions in Windows. I’m sure a Windows user will be along soon, or you could google resetting file permissions in Windows. Or you might try a search in this forum for other posts which raise similar problems.

It’s just that I saw your post and remember permissions issues following an update coming up a number of times here.



I have the same problem. The only place I can save the file is a place called “Home” which is under Users/my name/scrivener. Cannot save a compiled file anyplace. Cannot convert old Scrivener files to new format
Tried changing permissions. Possibly did it wrong. Tried running as Administrator. Nothing worked.
Old versions at least read old files but will no longer save (saved before update)

In windows if you go to the file manager, Find the file. Right click. choose properties there will be a box to check for read only. If it is checked uncheck it.

OK Folks
I don’t know how many others have had the same problem with storing a compiled file or storing a file in the latest version of Windows 10 but here’s the answer.
In the latest version of Windows10 iI solved the problem by disabling Real Time protection in Virus & Threat Detection. Apparently Scrivener is considered an unapproved the MS world. Excluding Scrivener from Real Time Protection did not work. You have to shut off the virus protection.

Using the latest official Windows 10 (1803) with updates.

I use Microsoft’s real time protection and Webroot. I’ve excluded nothing. Both current versions of Scrivener work fine. So there is probably some conflict in addition to Microsoft. It also works fine with Windows defender and Nod32. Perhaps your antivirus AND Windows defender have an issue causing a problem with Scrivener.

I am having the same problem,
Except it shows a different "scrivener cannot save to a project.scriv folder.
The folders where I’ve tried to save are even in different hard drives, where I have nothing from scrivener. But will just not do.
For some reason, even if I am logged on as administrator (windows 10), some files in the folder which scrivener is using (right where I don’t want it) I check the folders and files and indeed some are read-only, but even if I tick it off they return to read only.

Any help will be appreciated, this is so annoying and even paralizing (also, is Scrivener going to address this issue since it’s not just one user?)

I’m running Scrivener on Win7 and every time I start it up I get this message. This is just since I have installed the update Version: - 14 Nov 2019.
It is also very slow in it’s auto save function and freezes up for short periods so you have to wait for it to comeback to a flashing cursor in order to keep writing, very frustrating.
Before that it was the licensing problem, which the above update was released to cure. That seems to have worked, but is now generating these new problems.
Scrivener is becoming a very buggy piece of software. It’s a shame as it is a great tool for writing, but not worth the hassle if they cannot get it sorted out. The issues have been going on for a long time now.

I was having this same problem.
I don’t know if my issue is the same as yours.
I have windows 10, and I use google drive to sync my scrivener folder.
I kept having this issue and discovered it happened every time that google drive synced my folder when I had scrivener open.
As google drive synced, it locked my file and wouldn’t allow me to save it.
I found if I exited out of Google Drive sync I could once again save the file I was working on.
I would check to see if you have some sort of backup software or other program that may try to use the file the same time you are and then lock it up.

L&L advise against using Google Drive to sync Scrivener. See the advisory here:

I’m having the same problem. I updated to v3 yesterday. The tutorial saved fine. I then tried to open my project from the older version. It gave this error. I crested a new project and tried to import the doc from Word. Got the error. Started another new project and copy pasted text into Scrivener. Same error. It pops up like every 2 seconds with a list of every document I have in my project. I even tried uninstalling and reinstalling, saving projects in a different folder, nothing worked. This is super frustrating. I have limited time to work on this and all of it yesterday was spent just trying to get Scrivener to work.

This is likely due to your Antivirus program, as many other users have found.

As a test, disable your AV. If Scrivener runs normally, whitelist Scrivener in your AV.