Scrivener update 2.3.1 issue -> Scrivener won't open!

And it’s a BIG one. I don’t know if it happened to anyone else, but my Scrivener app just won’t open up after I quit the app after updating to the 2.3.1. The app icon’s image changed as well, to the paper with pencil, paint brush, and ruler image that the mac (I presume) defaults to when it doesn’t register an image file for the app icon.

Basically what happened was I opened the app, updated to 2.3.1, then quit it after it didn’t relaunch when I clicked “Install and Relaunch”. After that the app icon changed and I couldn’t open Scrivener anymore. When I right-click it it still behaves like it’s the Scrivener app icon: it shows my recently opened Scrivener files and such. I restarted my mac, and it’s STILL like this. Fortunately the 2.3 version of Scrivener is still here, so I can still use it, but I’m afraid to update it again in case it happens again.

I’m really confused. I don’t know why this happened.

Image of the app as it is now:

Screen cap of when I right click:

For now I’ll just use 2.3, but I won’t be updating until I know what’s up.

I’m using a 13-inch Macbook Pro with an up-to-date OS X Lion.

Yes, more or less exactly the same for me. Except that the icon works fine.
So, I dragged the older version out of the trash and put it on the desktop for the meantime, and all works fine.


Sometimes automatic update doesn’t work. It has to download a .zip file, extract it in place of the older version and then relaunch. If the entire Zip file does not download, or the extraction did not perform correctly, then you can end up with a toasted installation. It’s not anything to worry much over though, because the application has nothing to do with your data and settings. It’s just the core that runs them. Download a fresh copy from the website and replace the broken copy with that, you should be back up and running.

Alas, that (downloading the dmg from website) didn’t work.
No problem though. 2.3 is fine, and I’m not planning on getting Mountain Lion anytime soon.


I’d really recommend installing 2.3.1 - please don’t stick to 2.3 as there are bugs in it. When you say that downloading the dmg from the website didn’t work, what do you mean exactly? Be sure to pick the version that works on your system, as there is now a version for 10.6+ and another for earlier systems.

StrayXIII - your problem is definitely that Scrivener hasn’t installed correctly (that’s why the icon isn’t showing up correctly), so you do just need to download from our site and re-install that way.

All the best,

Yes, I downloaded the correct version.
I’ve sent you a PM with further information.



I’m having the same issue. I have Mac 10.7.2. I installed the 2.3.1 update while my current version was open. I restarted the application, but I keep getting crash messages when I try to open it. I tried downloading the full version of Scrivener from the website, but it also gives me the same crash messages. I can see my files, but they won’t open without crashing. I sent an email to tech support.

Hi Sandi,
I’m having the same problem. Don’t suppose you’ve had an answer from tech support that you can share? I’ve emailed them also.



I’m investigating this right now, but it basically seems that the 10.6+ build of Scrivener 2.3.1 will not run on early versions of Lion. I have an idea why this might be, and have just finished installing 10.7.0 onto a spare partition to investigate properly (I can reproduce it). In the meantime, though, there are two simple fixes for users of early versions of Lion - either:

  1. Update your system to the latest version of Lion;


  1. Download and install the version of Scrivener 2.3.1 that is labelled as being for 10.4 - 10.5 on our downloads page ( ). This will work fine on later systems, too, it just hasn’t got full Mountain Lion support.

Sorry for the inconvenience.

All the best,

Thanks bunches, Keith, just re-downloading it worked fine!

This should be fixed in the 10.6+ version now, too. Phew!

Thanks to Astrid, I’ve got it fixed. Upgrading the OS from 10.7.2 to 10.7.4 worked.