Scrivener won't compile.


I wonder if anyone has a solution for this. All of a sudden Scrivener 2.0.4 won’t compile. When I click the compile button in the compile dialogue it just hang there as though it’s about to compile but never does. I can click cancel and the compile dialogue goes away, I can re-click the compile button and it appears to start compiling again.

If, however, I compile with no documents selected it will work producing a single blank page.

I’ve tried with projects that I know have compiled and they fail too. So I’m guessing it’s not the project itself.

The problem seems to be related to Project Statistics as well. When I try to look at them Scrivener does much the same thing as when I try to compile.

I’ve tried removing the scrivener folder in Application Support and letting Scrivener recreate it, but that doesn’t work either.

Any help on this would be most appreciated.


There was a bug that got into 2.0.4 which messed up compile on Tiger, but Keith fixed it in the betas. Go here to download the latest and install that and you should be good.

Many thanks, worked like a charm.