Scrivener won't launch

So I have this interesting issue where Scrivener does not fully launch. It sits in the process list, eating 30% of CPU resources, and has to be manually killed. It very rarely launches correctly. This goes both for the main program, and for the installer and uninstaller. Rebooting the PC seems to make it more likely that the programs will run, but I’m careful so as to not introduce observation bias.

  • The problem occurs both with the 1.9.9 version, as well as the v3 Beta (indeed I have not been able to start the Beta installer successfully)
  • No similar issues with any other software
  • Windows 10 Professional, all current updates and patches
  • Yes, I tried disabling Windows’ AV and the Windows Firewall. No dice. I am not using third party products.
  • I used wireshark to try and see if the software tries phoning home, but could not id anything relevant
  • I have not seen anything obviously relevant in the Windows event log, but most of that is too cryptic for me (I am more a UNIX person, myself)

Seeing as how it’s both the installer/uninstaller and the main program, my money would still be on some sort of “calling home” functionality that fails. Is there some way to enable a debug mode, or a log, or whatever?

Anybody have any ideas?

I’m having the exact same issue, Scrivener and Scrivener uninstaller only show as background processes and each takes ~20% CPU as a background process. Would very much like to hear some suggestions on how to solve this issue as well.

I also have this problem (Win7 with all latest Important updates applied). I’ve tried re-downloading and re-installing, but still the same. After trying for many attempts the other day I managed to get it to load, but it doesn’t want to play at all today. Task Manager shows it using 25% CPU and around 16-18MB memory.

OKAY so, after about a week of talking it through with scrivener support here’s the issue I personally had. I run two drives on my computer, one SSD with windows on it, my C drive, and a hard drive (spinning rust), my D drive, with everything else on it. I had installed Scrivener on this drive.

To diagnose my issue:

  • Found the ScrivenerLog.bat file. Shift + Right click the ScrivenerLog.bat file and choose “Run as administrator” from the context menu. This opened a console window with Scrivener loading progress messages and will also generate log files within the log subfolder.
    My Log had this to say at the bottom:

Debug: Runtime Location: "D:\programs" Debug: Installed Location: "C:\WINDOWS\system32" Debug: WARNING: Runtime and Installed Locations do not match.

If that’s the same issue you have, I’ll go ahead and add what I had to do to solve it. Even now I keep my fingers crossed though.

How we fixed this:

  • If you can’t use the uninstaller like I did (and you also can’t use the control panel uninstaller), delete all the files you can find of the scrivener installation.
  • If you can’t do a normal uninstall, you’ll also need to delete scrivener’s entry from your registry. Do this by going to regedit and looking in the subfolders. Delete the whole scrivener folder on the registry.
  • Then, make sure you’re logged in as an administrator, and download another install package from Lit&Latte.
  • Then, right click and do ‘troubleshoot compatibility.’ I found that windows 7 was the right compatibility. Then it installed just fine for me, this time I installed it on the C drive where it wanted to go.
  • However, when I went to run scrivener, no dice. That’s because you have to set up compatibility for the program too, and on every user account you’ll want to use with it.
  • Tell the compatibility you want to do it manually, and then do ‘it ran on a previous version of windows,’ when it asks what version, choose windows 7. Then test it. If it works, tell it to save those settings.

I hope this helps you, or anyone else who might get this problem. Shout out to Nicky (if that is his real name) for tech support on this.

Thanks Catty404. I’m running it on a Win7 laptop with only a C drive, so my problem isn’t the same as yours. However, I did run the debug batch file which may have given some hints. The log file contains the following excerpt:

[Lots of other debug messages showing it loading normally, but then a number of the font messages ending in…]

Debug: No PostScript name for family: "SimSun" Debug: No PostScript name for family: "MS PMincho" Debug: No PostScript name for family: "Meiryo" Warning: QSettings: RegEnumValue failed: Warning: QSettings: RegEnumValue failed: Warning: QSettings: RegEnumValue failed: Warning: QSettings: RegEnumValue failed:
[these Warnings continue ad infinitum]

Thinking it might be a Registry issue, I completely uninstalled and then re-installed. There was a slight change in that now the “New Project” window appears, but is empty and the window is unresponsive. I think I previously had it set to open the last opened project, so this window wouldn’t have appeared anyway.

When I tried the other day, I just left it ‘loading’ and it did eventually load after about an hour or so (I’d gone off to do other things so don’t know exactly how long it took).

In my case it seems to have to do with the fact that Scrivener immediately wants to open the last project I’ve opened. That is, usually a project on my NAS. If I’m working on my desktop there’s never a problem. When I’m working on my laptop outside, where I have a secondary Wifi access point, things depend on my connection. Most times things are fine. But sometimes the program seems to have a hard time locating my network files. Then those infamous “not responding” messages show up and I usually just have to quit for the day on that machine, because it’s impossible to reconnect normally.

I think things would be significantly better if Scrivener started up without automatically loading the last project. Is this something I can select somewhere?

Well, if you open Preferences it is the first thing you see, at the top of the window under General → Startup…

Thank you! I guess I haven’t looked hard enough. At all. Completely off topic, but I also like the option to show the full path. No more working in the backup file for me.

I’m having the same problem with my windows 10 Lenovo laptop. I only have one hard drive. I used to be able to get it to launch if I rebooted my laptop, but then that stopped working consistently so I uninstalled and reinstalled and it worked a few times. The I found the hanging processes others spoke of and I could end those and try again but now it just hangs on opening my most recent project and won’t let me edit or access the menus - just an hourglass. Here’s what the debugger shows.

Debug: Loading project: “C:/Users/rathb/Google Drive/Writing/xxxxxxx.scriv”
Debug: Scrivener: loading document ID: 242 : “xxxxxxx”
Debug: Scrivener: loading document ID: 212 : “xxxxxxx”
Debug: License server started.
Debug: Starting communication.
Debug: Communication enabled.
Debug: Message sent to server, waiting for reply.

Please help!

After much frustration and uninstalling and reinstalling and swearing, I downloaded the October 2018 version and now Scrivener is launching again.

Here’s how I solved the issue: Cancel all the background Scrivener processes. Relaunch the program.

I have had a hand few of times where the program wouldn’t launch. Reading your post made me think to open the Task Manager and see for myself. As an experiment, I decided to close the processes and launch the program again and it really worked! Before, I’d restart the whole computer to make Scrivener work again, which was a pain. The solution I mentioned above was such a simple fix, I’m surprised I hadn’t thought of it before!