Scrivener won't load (OS X 10.8.1)

I just upgraded Mountain Lion to the 10.8.1 release from Apple, and ever since then Scrivener has not loaded on my MacBook Air, 2011. It worked well on the Mountain Lion 10.8 release. It quits immediately after I click to open it, and offers to re-open it. But that doesn’t work either.

Is there anything I can do to run the program?

Thanks.

Try uninstalling and reinstalling it?

Thanks - I’ve tried re-installing it twice, but that doesn’t work. I’m not sure what to do, as I’m in the middle of writing a textbook chapter with it. I may have to try something else.

When it quits, I’m assuming that means it has crashed? You get a message from the operating system stating that the software has stopped working? Have you tried starting the software up with the Shift key held down? That will keep it from loading any projects it is scheduled to load automatically. If the problem is an imported resource in one of those, that would at least get the program started and point the way toward an ultimate fix.

Thanks for the suggestion. I hadn’t tried doing that, but it doesn’t work either. I receive the same message in a pop-up window.

"Scrivener quit unexpectedly.
Click Reopen to open this application again…

Below the message, there are three boxes
Ignore Report… Reopen.

It just shows the same message again, with or without the Shift key pressed.

All right, it might be best if you send in your crash report logs to tech support, or if you’ve been using the Scrivener reporter to send in your reports, let us know the e-mail address you used to send them in so we can look it up.

If it’s helpful info, Scrivener starts normally for me on 10.8.1 on an 11 inch Macbook Air (mid-2011).

  • Susan

I installed 10.8.1 yesterday and am having the same crash problem. A timely fix would be appreciated.

I’ve just upgraded to 10.8.1 and have had no problems with Scrivener.

Mark

I appreciate that, but I don’t know anything about your problem—and since this isn’t a universal issue for everyone on 10.8.1, I need to know a whole lot more than just that. What version of Scrivener are you using, for instance? Is it the sandboxed version from the Mac App Store, or the direct-sale version? Do you have a lot of plug-ins installed, and if so did you audit them all for 10.8 compatibility before upgrading? We’re finding 9 times out of 10, people reporting crashing on a brand new operating systems are in fact not having problems with Scrivener at all, but old out of date and conflicting software they never checked before upgrading. So in cases like these there is nothing for us to fix, but sometimes the crash reports can show evidence of conflicts and we can point out which things they should update or uninstall. Have you followed all of the above recommendations in this thread?

I have a similar problem. Just updated to 10.8.1, but I can’t even generate a crashlog. Scrivener won’t load.

The Console will sometimes have information if the program doesn’t start. I’m running 10.8.1 on my machine as well, and all various copies of Scrivener are running fine, so in theory we should be able to help. Have you gone through the above troubleshooting advice?

  1. I don’t like change so I am still running older OSX.
  2. I don’t like change so I am still running older OSX.

Ioa, does the open command in terminal work the same as 10.q where q<8? The only reason I ask is that you get even more feedback for some errors using open /Applications/Scrivener.app for some errors (permissions are the most obvious ones).

I’ve tried starting it with the shift key held down. I will try reinstalling this evening.

Yes, you can still use open to load things in 10.8.

HopeSprings, if you do get the error box described where you can choose to “Report” when you do so, expand the error to show more info, and then copy and paste all of that text into a file and attach it, or if you’d rather, send us an e-mail with that info and a link to this forum thread. If you just click Report that goes into Apple’s event horizon and we never see it.

Also, there is a known conflict between Eset and the sandboxed (Mac App Store) version of Scrivener that will cause a crash on load.

Hi,
I downloaded again and reinstalled and everything seems to be working now.

Great, glad to hear it!

Anyone experiencing this problem, please try the steps I outlined here:

https://forum.literatureandlatte.com/t/scrivener-2-3-1-crashes-on-open-os-x-10-8-1/19351/1

It seems that something about the 10.8.1 updater is causing problems for many applications, not just Scrivener, owing to a bad OS install that breaks something deep in OS X’s interface code used by many apps. The instructions in the thread above - gleaned from instructions from developers of apps with customers facing the same issues - should hopefully get people up and running again.

Thanks. I wasn’t sure what the crash report logs meant, but then after reading one of your later posts, I realized it is the “Report to Apple” log that the crash notice offers. I’m sending two attached files in RTF. One is with the normal effort to load my project, and one with the shift key held down. I’ve also tried renaming the *.scriv file that is loaded, and it still gives the crash notice without loading.

Thanks for your help.
Scrivener.Log.2012.8.31.NoLoading.txt (40.4 KB)
Scrivener.Log.2012.8.31.LoadingFile.txt (40.6 KB)

Jaybo, did you go through the steps that Keith posted earlier in the thread? Your crash logs do match the type of signature associated with this problem. The parts of the program that are crashing are more accurately defined as being fundamental parts of the operating system that have broken and are causing the surface application—Scrivener in this case—to crash.

From what I can tell, this doesn’t have anything to do with your projects. The crash happens far before getting to the point of even trying to load the project.