Scrivener won't open

Hi there. This problem began as intermittent, but now seems to be pretty much constant.

I simply cannot open Scrivener. It just won’t start. I’ve scanned the forum threads here in hope of an answer, but unfortunately I’m much less tech-literate than most of the users on here seem to be. Half the time I don’t know what they’re talking about.

Please can someone help? The pressure is on to make wordcount every day, and I’m feeling pretty stressed.

I’ve seen people recommend to delete Scrivener and re-install it, but this idea makes me nervous as I don’t know how to do it safely without losing my work. To compound the issue I initially bought the program on CD, and have since moved house, so god know where that CD is now.

Advice/help much apprecaited.

The only work that you might lose would be your scriv project folders and files. Do you remember where you save to? If so, you can copy/move the folders somewhere safe and then completely uninstall/reinstall. I would suggest using a heavier-duty uninstaller than the standard windows one, like Revo. It checks the registry and hard drive for files and keys that aren’t deleted by a standard install. Just exclude your safe files (the project folders/files you copied/moved earlier) if they come up in the drive scan, and you should be fine. Reinstall from the L&L page and reinput your registration info (if that key is deleted from the registry during your uninstall).

Edit: If you don’t know your registration info and don’t have an email with that info, before uninstalling open Regedit. Navigate to HKEY_CURRENT_USER\Software\Scrivener\Scrivener\Registration. Copy your reg info (name, serial number, spaces exact - use ctrl-p and -v). Easier than an email to customer support later.

Before going through the uninstall, etc., I’d check whether it’s just an issue with a recent project not opening. If Scrivener is set to automatically open the most recent project you were working on, it could be stalling out in that process. Changing the name of that project should bypass the problem in that case. To do so, use the Windows file browser to find your project’s folder (e.g. if your project is named “My Great Novel”, its folder will be called “My Great Novel.scriv”) and then right-click the folder to rename it (from “My Great Novel.scriv” to “Do Not Open Me.scriv” or what have you). Then you can try launching Scrivener again. You may get a message that the most recent project couldn’t be found, which you can just click OK to, and ideally then it will open the New Project window, whence you can create new projects or open other ones.

If that much works, it suggests the problem is particular to that project, and we can then look at ways of fixing it to open properly.

As far as the uninstall goes, it only removes files created by the installer. Your projects are not saved inside the program; like Word documents, they’re just files (in this case folders) on your hard drive, saved in Documents or wherever you created them. Uninstalling Scrivener just means you can’t open those projects in Scrivener; it doesn’t delete the files any more than uninstalling Word erases all your Word documents. If you don’t have your licence information and aren’t comfortable going through the registry as Sanguinius suggested, you can look it up from here or email sales AT literatureandlatte DOT com with your name and the email used when purchasing Scrivener, if you remember it, and we can help you out.

Thank you both for your kind help. OK: I tried MM’s suggestion, renaming the project, and this seems to have been effective. PHEW. I can open the project, and so I can work again.

Quoting MM: “You may get a message that the most recent project couldn’t be found, which you can just click OK to, and ideally then it will open the New Project window, whence you can create new projects or open other ones.”

I did get that message, but then needed to click through into “recent projects”, then into the actual “project” file, in order to open my manuscript. In theory I could go through this process each time, but I’d like to resolve it if possible, so I can simply open the project each time I need to, no problems.

As MM said: “If that much works, it suggests the problem is particular to that project, and we can then look at ways of fixing it to open properly.”

Any suggestions on this front? Thank you both again for taking the time to help me with this.

Sorry for the delayed reply; I’m away without much Internet access at the moment. It sounds like you are able to open the project successfully once Scrivener is already open, correct? If that’s so, it’s probably just stalling out on opening both simultaneously because of how much needs to be loaded in the project. I’d try simplifying the view to see if that helps, e.g. close it next time with just a single text document loaded in the editor rather than a whole Scrivenings session or a bunch of images on the corkboard. Every binder item represents a separate file on the computer, and the more you’re loading into the editor on startup, the slower it will go. Usually just cutting back on this initial load will fix the problem.

Other possibilities are a corrupt media file or damaged settings file for the project, but I’d expect in that case the project still wouldn’t open even without being part of the Scrivener startup process. So give the above a try first.

As far as automatically loading projets, this is a setting in the General tab of Tools > Options, to load whatever projects were open when you exited Scrivener. Default settings make closing the last project (e.g. by clicking the Window’s red “X” button in the project window title bar) also close Scrivener, so that last project open will be the one that automatically loads. You could get multiple projects automatically opening if you had them all open and then quit Scrivener via File > Exit without first closing the individual projects. So as you’ve probably seen by now, after having opened your project under its new filename, Scrivener would have automatically loaded it the next time you opened Scrivener if you used your usual process of closing the project and Scrivener together.

The “Recent Projects” menu is just a convenience list of shortcuts to the last five projects open, so once you’d changed the file path, that proect was removed fro the list (the “shortcut” file path woud no longer have been correct). It’ll be re-added once you open the project by browsing directly to the project folder and opening it via the yellow-icon “project” .scrivx file inside. The Recent Projects menu works even if you turn off the option to automatically load the most recent project when starting Scrivener, so even if that’s still not working for this project, you should be able to still save some steps in future by turning off the auto-load option, then launching Scrivener and chosing the project from the top of the Recent Projects menu in the New Project screen.

Dear MM,

Thank you once again for your generous help. And apologies for my own slow reply – I’ve had a sick toddler.

The project is now opening, and I can work on it without any problems. The only odd thing now is an error message that appears every time I open the project. It reads:

Errors reading project
Error:Error reading template info: Line:1 Column:2 Error:1

Once I click “close” on this error window, the project opens with no problems.

I will try the options you suggest. It’s great to have this background knowledge on how Scrivener works, too. Thanks again. You’re a champ :slight_smile:

Sorry to hear about your little one! I hope everyone is healthy now.

The error message isn’t anything to worry about. It indicates an error in the templateinfo file of the project, but the file is only used to auto-populate the “category” and “description” fields when using Save As Template. Deleting the file with the project closed will prevent the error message recurring and will not affect anything else in the project:

  1. Close the project.
  2. Open Windows Explorer and locate the project’s .scriv folder on your hard drive.
  3. Navigate into the “Settings” sub-folder.
  4. Delete the file called “templateinfo.xml”.

Once you’ve done this, you should be able to reopen the project without seeing the error. If you ever use Save As Template from the project, a new templateinfo.xml will be created with the information you enter at that time.