Scrivener Won't Start

I bought Scrivener some years ago and it has been at least a year since I last used it but I have now received a commission to write again.

I started Scrivener up this morning and it said that I had an unlicensed copy which is not true.

It also said I needed to upgrade it, so I did.

Now it won’t start!!

Am I doing something wrong?

Please help ASAP. I’m desperate.

Same here. After years of use on a very regular basis (less than 12 hours ago) I am told this is an unlicensed copy and then it dies.

Thankfully re-entering the license key fixed mine.

I prefered the threat on a count down rather than the hard kick me out.

It appears the license checking code is still flakey. I think a little more logic is required.

My life is in Scrivener and I am now getting frightened this could happen on the day I need it. Obviously I know I can get to the files, but when you are working to deadlines, this is not that comforting.

Perhaps Word and Onenote are a better option after all?

I can’t start Scrivener now, so re-entering the Licence code is not a solution for me.

I re-downloaded the Windows program and re-installed it but still no luck. :frowning:

What’s going on?

Why won’t Scrivener run?

This is VERY worrying and frustrating. I need to get on with my work but I can’t.


With hours of rebooting, reinstalling and jiggery-pokery, I’ve manged to get Scrivener to open! Woo hoo!

And, again, with a fiddle or two, I re-applied the Serial Number and I THINK I’m back to normal.

Goodness me! What a weekend!

Me too. It was fine yesterday but today it just won;t start. I’ve run compatibility tests and get the response that Scrivener is incompatible. The compatibility dialogue does seem to think i’m running Windows 8 - and there is no option for Windows 10 which is what i’m on. I’ve uninstalled and reinstalled - no good. I’m still on my trial period and would love to purchase - but not at this rate. It looks like I’ve already lost a lot of work

I just purchased Scrivener this morning and it didn’t launch at all (initially it didn’t want to start the installer either).
While the compatibility settings did help start it once, as soon as I closed the program I could not relaunch it anymore.

So I read all the past posts here regarding this issue and went to the Previous Versions section. Some of the updates mentioned Microsoft.NET 4.5 (runtime) apps, so I tackled that here in my workstation.

I went to:
Control Panel > Programs and Features > Turn Windows features on or off >
+.NET Framework 4.8 Advanced Services
…and enabled all the services in it.

Compatibility Setting:
Windows 7 (i also had to use Windows 7 for the installer)

Now I can relaunch it with no further issues (afaik).
Maybe this will help some of you too.
Hopefully they will issue an update/upgrade that won’t give us any further headaches like this–especially for us who just bought it (Mac+Windows bundle too).

Good writing everyone.

I don’t see .NET Framework 4.8 Advanced Services on my Win7 Pro 32bit system. Nor do I see
.NET Framework 4.5 either; despite it saying it’s installed.

I’ve updated my Win7 32bit system with the latest updates + optional updates.

I tried this; but it doesn’t make a difference.

What happens is the following:

  1. Run Scrivener (w/o compat. settings)
  2. Reopen a project. Once I select the project’s .scrivx file, Scrivener promptly closes.

Then I tried the “Right-click,Run as Administrator” option: It’d open, But when I click on the “Open Existing Project”, Scrivener just hangs there. I’d have to taskkill it.

Then I tried:

  1. Run Scrivener w/ Compat settings set to WinXP (stupid really since iirc, 1.9.8- have dropped support for XP).
  2. Open Existing Project. → produces a “Scrivener has stopped working”.

As well as:

  1. As redundant as this may seem, I tried compat settings set to Win7.
  2. Open Existing Project → Scrivener just closes.

Then, I used WinDBG .

  1. Run WinDBG
  2. Open Scrivener.exe
  3. Go
  4. Open Existing Project
  5. Crashes with the following:
Loading project: "C:/Users/cc/Documents/x.scriv" 
ModLoad: 733f0000 73400000   C:\Windows\system32\NLAapi.dll
ModLoad: 6a6f0000 6a700000   C:\Windows\system32\napinsp.dll
ModLoad: 6a6d0000 6a6e2000   C:\Windows\system32\pnrpnsp.dll
ModLoad: 6a6c0000 6a6cd000   C:\Windows\system32\wshbth.dll
ModLoad: 744b0000 744ec000   C:\Windows\System32\mswsock.dll
ModLoad: 74370000 743b4000   C:\Windows\system32\DNSAPI.dll
ModLoad: 6a6b0000 6a6b8000   C:\Windows\System32\winrnr.dll
ModLoad: 10000000 10045000   C:\Windows\system32\spool\DRIVERS\W32X86\3\hp1100sd.dll
ModLoad: 08dc0000 08e85000   C:\Windows\system32\spool\DRIVERS\W32X86\3\HP1100GC.dll
ModLoad: 0bc80000 0beb5000   C:\Windows\system32\spool\DRIVERS\W32X86\3\hp1100su.dll
(cd0.1038): Access violation - code c0000005 (first chance)
First chance exceptions are reported before any exception handling.
This exception may be expected and handled.
eax=09b26b28 ebx=0000243c ecx=00000000 edx=0031003b esi=0a8ba218 edi=09b26b28
eip=0bcc5a39 esp=0012c740 ebp=0012cbb0 iopl=0         nv up ei pl nz na po nc
cs=001b  ss=0023  ds=0023  es=0023  fs=003b  gs=0000             efl=00210202
0bcc5a39 893a            mov     dword ptr [edx],edi  ds:0023:0031003b=00000000

Which as far as I understand, points to my printer driver.

Then an idea hit me.

I went into my device and printers, removed all of my printers listed.

Ran Scrivener via WinDBG again.

And it works. Scrivener finally loaded the project. I went and opened the old project and that also worked.

So, from I’m seeing, Scrivener is enumerating the printers and somehow doesn’t seem to like my HPP1102
printer. Removing the printer allowed Scrivener to run.

Being curious that I am, I re-added my HP P1102 printer and tried running Scrivener. It still works.

Sooo in conclusion, (and of course, ymmv), if Scrivener crashes… try removing the printers and running Scrivener again. If it runs, Scrivener doesn’t like your printer; but once you’ve got Scrivener running again, I think you can re-add your printers. That said, if your system doesn’t have a printer installed and Scrivener crashes… this post might not even help you.