Scrivenings separator not visible

I have been using Scrivener for several years, and have recently installed it on a new Mac.
When I open my projects in scrivenings mode, I cannot get the separator to appear. I have tried all options—corners, dashed line, bookish and dividers—but no success.
Hence text looks like one long document, with headings and subheadings, but no visual separator.
Is there a preference somewhere I have overlooked?

I think this is the clue, in that case. Do you have View ▸ Text Editing ▸ Show Titles in Scrivenings enabled? If so, the new default setting in Appearance: Scrivenings: Options, Do not show separators above titles, will be in effect.

Thanks Amber. sorted