Scrivproj/Scrivx Problem - Issue solved


I am currently facing multiple errors when trying to open my projects datinmg from 2017 to 2020.
Upon opening, I am told that the project “seems to be of an older format” and that I should search for a *.scrivproj-file.
I have so far found out that in the meantime these files are named *.scrivx - all of them are there, but both my Mac Desktop (3.22) and my iOS-version (1.2.1) sport the same problem.
Yes, I made the mistake not to store the files locally but on my dropbox. But so far, it all worked perfectly -last time so in February 2021. This morning the problems first occurred, I hadn’t opened any of the projects in the meantime, neither on my Mac nor on my iPad.

Please advise how to make Scrivener acknowledge the *.scrivx-files that are actually existing.

Bertram Quadt

On the Mac, you should have what looks like a single ProjectName.scriv file. This is a package file, which is essentially a collection of folders and files that are meant to be together, so MacOS displays them as if they were a single file. However, Dropbox doesn’t understand the package format, and will show you the full contents of the package as files and folders.

The *.scrivx file is a single file within the ProjectName.scriv package file and does not contain the entire project data. If you use the web interface of Dropbox, you can easily download the wrong item. It is possible to download the entire package via the Web interface of Dropbox, but it takes a bit more work and it’s much easier to just use the Dropbox client on MacOS to make sure it syncs everything down to your hard drive. When using the Dropbox client, you do need to make sure that it has the setting that allows it to “optimize” your files (that is, only download the files it thinks you need) turned OFF, or it may only sync portions of your projects to your local hard drive.

Scrivener for iOS should be able to see the full project data if it exists in Dropbox, if it is pointed to the correct top-level folder in your Dropbox account (by default Apps\Scrivener.)

How did you get these files on Dropbox, and where are the rest of the projects?

Thanks, devinganger
My projects always have lived on dropbox, until now without any problems.
I have dropbox embedded in my Mac finder and store the files there. They are synced automatically with db. So from my (admittedly limited) point of view, all files are existent on my macs hard drive - even there I found the scrivx-files by right click → show. All other files seem to be there too.
Smart-Sync update on my Dropbox is switched off per default.

The problem started this morning when trying to open a project on my Mac on Scrivener 3.2.1
I was prompted to update to 3.2.2, problem persists.
Some projects seem to work on my iPad, I can however not fully sync here at the office due to limited bandwith, the sum total of my projects is around 25GB

I am currently at the office and will have to look into it more closely once home in 4hrs.

That’s a likely explanation.

Hello lunk,

don’t think so. Problem exists on my fully synced Mac at home as well. Projects have been untouched since March. When I am working on my iPad, I normally am on a journey and sync via mobile or sat phone. So far never any problem.

Before trying further things, I would definitely make a(n off-DB) safety copy of whatever project you mean to tackle the problem with respect to.

Your response to devinganger sounds like you know very well what you are doing, but at the same time your original post certainly makes it sound like you were trying to open .scrivx files — which is the wrong thing to be doing.

So, just to be sure: Your scriv projects have the extension .scriv and you should be trying to open them (and not something inside of them) directly from the Finder.

1 Like

Issue solved!
The dropbox helper app residing in the mac menu bar was not running - my bad, I had discarded it as a start item.
As soon as it was back in the menu bar, all worked like I am used to.
All fine by now.
I will, however, make an off-DB copy to be safe rather than sorry.

And with thanks to GR: no, I didn’t try to open sctivx files - I just checked whether they were there and valid.

Do you have Scrivener on your work computer? Because if so, and you haven’t fully synced all of your Scrivener dropbox folder, then Dropbox isn’t going to necessarily choose to sync your most recent work instead of trying to sync the older files.

If you have a good copy of a project on your iOS device, then I suggest that you do this:

Move the project(s) from the “dropbox” section of the list of projects to the “on my i[Phone/Pad]” section. Then sync. You should see on your mac and at your office computer that the files will disappear. Be sure to let that all happen on all of your computers/devices before moving on.

Now, decide if you’re going to let your office computer sync everything, or if you need to exclude some folders from syncing. Once you have that decided/configured, move on to…

On your iOS device, move the projects one at a time back to the “Dropbox” section of the projects list. Sync, and then verify that the project opens properly.

As for the others, please immediately locate your backups folder (on Mac, it’s found under Scrivener->preferences->backup). Locate those files and copy all of the relevant ones to a non-dropbox location. They get replaced every time Scrivener makes a backup, so you don’t want that happening.

Then figure out which one is the newest, un-zip it (if it’s zip-compressed), and check if it will load into Scrivener. If you find good copies this way, delete all the bad copies in Dropbox, let the delete sync on all devices, and then move your recovered backup copy to Dropbox so you can sync with iOS Scrivener.

Thanks, Robert,

backup folder moved, I am also making a local copy of all projects.

But as I am happy to say and as I wrote above at the same time as your kind answer: issue solved.
It was the dropbox app on my Mac that wasn’t running.

1 Like

Emphasizing this because it’s a common cause of sudden mysterious sync issues. People will disable the Dropbox app for whatever reason, and then forget they did. But there have also been cases where Mac OS updates (silently) disabled startup items, or where a change in a site’s security software blocked uploads.

It’s a good idea to make sure that Dropbox is installed and running on all relevant devices as a first step in troubleshooting any sync issue. One simple test is to create an ordinary text file in the Dropbox folder and confirm that it propagates first to the Dropbox server and then to all connected devices. If it doesn’t, the problem lies outside of Scrivener.


Fantastic. Glad you got it figured, bq2210, and happily since it did not require a lot of bother to get things back to square.