scrolling bug on Scrivener 1.2

Hi - I recently upgraded to Scrivener 1.2 for my iPad. I’m using an iPad 6th generation, iOS 12.4.1., with a bluetooth keyboard. I’m having an issue with scrolling as I’m writing.

Once I’ve got a full page of text in the editor screen, there’s a thin toolbar at the bottom that is now cutting off the bottom line of text. I’ve applied all the different “Typewriter Scrolling” choices, but it makes no difference. In every case, the text scrolls at the bottom of the page, half-obscured by that toolbar.

I can hide the toolbar temporarily with the “down arrow” carat, but it pops up again when I resume typing.

The only remedy is to manually scroll up the cursor using a bunch of empty carriage returns… until I fill the page again and need to repeat the manual process.


Have you tried turning on Typewriter scrolling? That might resolve your issue?

Hey, you fixed the bug! Hah! I had no idea it needed turning on. I thought that selecting it in settings would do it.

Thank you @astaff!


I am getting this bug on iPhone XR.

CONDITIONS: zoom set to 100% (also tested at 120% with the same result). Keyboard row On or Off (from settings > Editor). Write in portrait mode.


  1. Open a document in Editor.
  2. Write a few pages of text.
  3. Scroll up to the middle of the document OR scroll to bottom of the document
  4. Begin typing down to the bottom of the page until reaching the keyboard.

RESULT: Text is partially obscured by the top of the keyboard as it prints to screen.
This occurs 100% of the time when in the middle of a document, and about 20-50% of the time when a new line begins at the bottom of the document.

Things get irritating very quickly when I’m having to manually scroll up every few lines of text in order to see what I’m writing.

Same bug I’m experiencing on an iPhone 7 ever since I bought and installed it. I see it was reported here six months ago… any progress on this???