Scrolling in Editor Window (Windows V3)

I wrote about this during the beta (though my posts appear to have been lost in the transition to the new forum): In Scrivener 3 for Windows, on some files, pressing Home or Page Up will take you to the second rather than first line of the file. Pressing the up-cursor will make the cursor disappear off the top of the window (rather than scrolling to the top line). The only way to get to the top line is to use the mouse to scroll up. I can find no pattern to which files this affects.

I remember this, but could never duplicate it. A couple of questions: Was this a new project or a converted v1 project? Did the document have any sort of imported text or picture? Do you see this in just one document in a single project, or does it appear in all documents and all projects? Are you in scrivenings mode or the single document editor?

I’m in single document editor. The project was started in Mac v2, if I recall correctly, edited in Windows v1, and was probably run back and forth once or twice between Win and Mac versions (including at least one Win1 → Mac 3 → Win 1 conversion. It then converted to Win 3 beta and has been edited in Win 3 and Mac 3.

What’s most confounding is that it happens in some documents in the project but not others. There are no pictures or imported text (other than the entire project as described above).

Does the “Show Invisibles” command (alt-shift-v) show anything unexpected in the top lines?

Is there formatting, or maybe a change in formatting, in the area. Or is there, or was there, a bulleted or numbered list in the vicinity?

I have sometimes found odd navigational anomalies at the top of documents, mostly involving blank lines, and having to manually position the cursor at the very top.

When I sync my sync folder, documents that had been edited in Word and saved as rtf before being brought back into Scriv typically have an extra blank line or two at the top that were not there in the original Scriv doc, or in the rtf when it was being edited in Word. I just delete them and all seems well.

No, “show invisibles” shows nothing unexpected on the top line. There only formatting in the examples I am looking at is italicization. There are no numbered or bulleted lists anywhere in the document.

Do you experience this issue in any new projects created with either Windows or Mac Scrivener 3? You might have picked up a conversion “error” along the way. If you are not experiencing this in new projects, that is probably what has happened. There are a couple of things to do if this is the case:

  1. Create a new project and copy in the stuff from the “issue” project - double-check as you go to make sure the documents are doing what they are supposed to do.
  2. Backup and send the problem project to L&L to look at - be sure to follow their instructions on how to do that.

It would be nice to get one of them here into the convo.

Yes, I have tried creating a new project, from the novel template. If I type in text from scratch – write a few grafs, then copy and paste many times – I do not encounter the problem.

However, if I go back to my original project and select all text in a file that has the scrolling problem, copy it and paste it into the new project, I encounter the same scrolling issue. This despite the fact that “show invisibles” reveals nothing out of the ordinary on the first line of the new (cut-and-pasted) copy.

FWIW, in both the original file and the new cut-and-paste version, when I cursor up to the first line (which does not scroll into view), the descender portion of the cursor remains visible and blinks – and when I use the scroll bar to reveal the top line, only the descender portion of the cursor is visible (still blinking).

Have you tried whittling down the text you are copying and pasting, to try to locate which portion of it is causing the problem?

What happens when you paste as plain text? Or first paste it into another program, then copy that and paste it into S?

1 Like

If I launder the copy through Notepad, the scroll problem goes away.

If I cut and paste directly from one project to another without including the first graf, the scroll problem occurs. If I cut and paste and don’t include the first or last graf, the problem persists.