Second editor does not follow the selection on the first one

The problem: some times, with the first editor is in corkboard mode and “automatically open in other editor” selected, a click on a document does not open the text on the second editor.
How to reproduce the bug?

  1. Goes to split view (two editors), and select one of them (the upper one, for instance) to automatically open the selected document on the other editor.
  2. Put the upper editor in corkboard mode and the second in view the document
  3. Create a multiple subdocuments that belong to a parent document.
  4. Open the parent document in the upper editor, the small cards for the subdocuments should be visible in corkboard mode.
  5. Click one of the cards, the text of that card should be visible in the lower editor.
    Everything right till now.
    Then:
  6. With the cursor in the lower editor (the one showing the text), click on the binder, in any other document. The clicked document should be shown on the lower editor.
  7. Finally, on the upper editor click on the same small card that was shown previsouly .
    What it is expected?
    It seemed reasonable that the lower editor should open the document just clicked.
    What really happen?
    Even with the upper editor selecting one card in the corkboard, and “auto show” selected, the lower editor keeps showing the last document selected in the binder.
    How to solve this?
    The only way to get the text back on the second editor is to click in another card in the corkboard in the upper editor, and clic back again on the first one. This shows the desired card text in the lower editor.

SYSTEM: windows 7 x64 with Scrivener for windows v 1.0.3.
I hope this helps to make Scrivener even better.
MB.

I have been experiencing the same problem, repeatedly, but not sure if this is a bug. It seems like the 3 panes (2 editors + binder) don’t interact as we expect them to. It feels like being boxed in. 3 seperate programs. The binder for instance, does not reflect the document of the current editor, only when you explicitly tell it: Reveal in Binder.

There is no way to store the settings of “Reveal in other editor” or “Reveal in top editor” etc. I tried to save this setting via Layouts, it doesn’t work. Hopefully this is a bug, too, and not intended.