see but can't open

my mac had a semi-crash today - the pref got messed up.
my problem with scrivener is that i can’t open two of my files - the ones that normally opened when i started up the program. i can see them in the folder i saved them in, but they won’t open if i double-click or if i try to open from within the program.

anyone have any suggestions?

Hi beatgenxer,

Reload the Scrivener application from a fresh dmg. It should drop a new preferences file into the preferences folder - you will have to reset all of your Scrivener preferences. Then open the Scrivener files from within Scrivener using OPEN.

It should work.


thanks lord lightning for the tip.
downloaded new dmg from scrivener
installed over the old version
those two files in question still won’t open up.

unless someone else has a suggestion, i might have to go to my backup copy of my hard drive (from two weeks ago)

The paths of the files that get opened up when Scrivener launches are stored in the preferences. Thus, if you delete the preferences or if the preferences get messed up, they won’t open. This is normal. All you need to do is open them again in the normal way - File > Open. Then, provided they are open when you quit Scrivener, they will be open again the next time you launch Scrivener.



thanks for that suggestion, but they won’t open that way (file -> open), even after reinstalling the software. and i tried to open them by double-click them, and by doing ctrl-click and choosing open that way.

What do you mean by “they won’t open”? I thought you meant that they didn’t open automatically when you launch Scrivener. If the files are crashing, then you need to do the following:

Ctrl-click on the .scriv files in the Finder and select “Show Package Contents”. Inside the project, look for a file called ui.xml and trash it. ui.xml is sort of a mini-preferences file that is stored inside the project to save information such as window size, whether the splits are open and so on (it contains no actual project data and thus is safe to delete). Sometimes if the preferences get messed up, this file can too, which can prevent a project from opening.

Hope that helps.
All the best,


i tried that and then file -> open, but they still aren’t opening.

the files aren’t crashing per se, and they aren’t opening automatically (that’s how i knew something was wrong when they didn’t open automatically when i launched scrivener) - they just refuse to open up.

i appreciate all the help you’ve given so far. any other thoughts?

  1. Open Console and see if anything gets written to it when trying to open the files. If so, let me know what (stuff about illegal NSTableView source isn’t relevant, so don’t worry if you see that).

  2. Send me one of the files (the smallest one!) to and I’ll see what is happening.

All the best,

i’ll email you the smaller file now. here’s what popped up in Console:

===== 2007 October 31, Wednesday 3:25:58 PM US/Eastern =====
2007-10-31 15:26:45.354 Scrivener[340] CFLog (0):
CFPropertyListCreateFromXMLData(): plist parse failed; the data is not proper UTF-8. The file name for this data could be:
/Users/*******/Desktop/stuff/word docs/Wrestling Novel.scriv/binder.scrivproj
The parser will retry as in 10.2, but the problem should be corrected in the plist.
2007-10-31 15:26:45.357 Scrivener[340] *** -[NSKeyedUnarchiver initForReadingWithData:]: incomprehensible archive (0xffffffb2, 0xffffffb1, 0xffffffab, 0x6d, 0x3a, 0xffffffca, 0xffffffd8, 0xa)

Ctrl-click on the file in question, select »show package« and you get access to all your files in rtf format. Nothing’s lost.

Edit: wow, a bit late.

Ouch. That looks likes a corrupt project file. What exactly happened with your Mac? It does look as though it has corrupted the project itself. As Jolanth says, if this is the case, you’ve lost none of your actual writing as you can retrieve it all from inside the .scriv package, but the structure and meta-data (labels and status) may well be irretrievable. I’ll take a look, though.

gmail isn’t sending the file, but i do see all the RTFs in the package. i guess i’ll just start taking those and remaking the folder.

thanks for your help everyone!

The problem with sending a project by mail is that it’s not a file but a package. You have to archive/zip them before you can mail them. This is true of “files” produced by many apps, now … Tables springs to mind, for instance.