Select all text remaining highlighted

Hello,

First off, I Love the product! Thank you for bringing it to windows!

Secondly, I couldn’t find this reported, but that doesn’t mean it hasn’t been. I just tried to select text in multiple files (in scrivening mode) to bulk change the font in all of them and got some very odd results.

The select-all function (edit menu > Select All or right click > Select All) only selected one file, so I used the shift key and page down functions to highlight all the text.

  1. I couldn’t change the font of all the documents at once - is this supposed to be prevented? If so, fair enough, but it would be nice to have.

  2. But more wierdly, all the files/documents remained highlighted, even when I clicked into one document to de-select it. The escape button didn’t work and each file would only de-select if I clicked into it. I shut down scrivener and re-started it, did a complete uninstall and re-install and the sub-documents I didn’t click into are still highlighted. I have over 40 documents so you can imagine that that is a tad annoying.

Is there a way to change the font of all documents at the same time that I’ve just completely missed? And if so, how do I de-select multiple documents? Or is this a bug?

I’m running Widowns 7 Ultimate on a Dell i5 laptop.

Thank you!

Hi,

Glad you’re liking Scrivener!

The way Scrivenings work right now, there’s not a way to select across multiple documents; that’s something Lee’s hoping to change after release, but it’s a pretty large project. Once that happens, it may become possible to change the font across multiple documents that way. For now, you can select multiple documents in the binder and then use the Documents>Convert Formatting to Default Text Style command to change the font of the selected documents to your default setting defined in Edit>Options under the Editor tab. When you run the command, you’ll get a bunch of options about what you want to convert; you can just select “Convert font only” at the top of the list.

This will also change the font without having to highlight the text in each section, which will spare you having to deselect it. There are, I think, two factors at play with the selection issue you ran into–first, by design Scrivener does remember your selection in a document, if you switch to another document without deselecting, and this is remembered inside the project (so reinstalling the program won’t affect it). In many cases, that’s useful, but obviously not so much in the instance where you’ve selected all the text of all your documents in order to make a change. (Naturally, once you can select across documents in Scrivenings, you’ll also be able to deselect all the text easily, so this won’t be an issue.) I think there’s also a bug, though, where text that wasn’t selected opens as selected anyway, and that hopefully Lee will be able to fix.

A tip, re: having to click in each document, if you hold down the Alt key, you can start at the first document in a Scrivenings session and just click the down arrow repeatedly to jump to each document. Significantly faster than using the mouse. :slight_smile:

The inability to select an entire Scrivenings session is something we definitely do want to fix. It’s a complicated problem, but it will be fixed. For right now, are you just wanting to reset your documents to your preferred styling? If so select them all in the Binder and use Documents/Convert Formatting to Default Text Style. All selected items will fixed in one shot; just make sure the focus is in the Binder, not the editor. This method is by far the preferred way to fix formatting, because it will be intelligent about it and preserve things like italic ranges by default, and can be set to preserve other aspects as well.

Until the selection boundary problem is solved, using Shift to get around it is only bound to produce odd results. The limitation isn’t in selecting text, that’s easy enough, it’s how to handle a selection that spans multiple literal files, and what to do when keys are pressed or features are used when this selection is made.

In short you are witnessing what is ordinarily a helpful feature: remembering the last phrase you selected in a document. Select a word in Document A, type in Document B for a while, return to A, and the same word is still selected. That persistence is backfiring when you force total selection in all files. When properly implemented, selections made to Scrivenings sessions will not be considered persistent, as selections are abstracted from file information at that point.

Heh, now it’s my turn to be the duplicator.

Yessssssss! I win, I win!

Or something.

I haven’t checked defaults in a while, but for reference, to spare your italics, etc., you’d want “Preserve font style” checked, assuming you don’t check “Convert font only”.

Ah, I thought it might be a helpful thing backfireing! I shall await later releases.

Thank you! I’ll just have to remember not to select multiple text in scrivenings if I don’t intend to export it or such like!

These scorched earth defaults should be removed entirely (if you want things to be that clean, paste and match style is good enough); I had thought they already were but I see they are still on, so yes in the time being make sure the options specified above are clicked.