Selecting the item currently selected in Binder[ADDRESSED]

It is well-documented in the Tutorial that there are a number of ways in which the currently selected item in the Binder may be something other than the current document. I believe this is a general problem with selecting the current item in the binder.

Steps:

  1. Open the Tutorial
  2. Switch to “Step 4.”
  3. Enable Two-pane mode.
  4. Activate the Second pane
  5. Switch to “Step 8.”
  6. Disable Two-pane mode
  7. Notice that “Step 8” disappeared, and “Step 4” remains.
  8. Notice that “Step 8” is still selected in the Binder.
  9. Try to select “Step 8”
  10. Notice that nothing happens

The use-case here is pretty simple. You switched to a document you wanted to use in the second pane. You decided you wanted to focus on it and get rid of the unneeded first pane. – It’s a minor issue, and one that is easily worked-around, but it is one that could be annoying to folks depending on how they use the app.

(Note that there are other ways to produce this same issue. The above example steps could also be solved by remembering the pane that changed most frequently and keeping that one instead of always the first, but it wouldn’t solve the issue with the Binder when the history feature is used. Different steps, different use-case, but currently it would hit the same issue.)

And here we see that I’m clearly still learning the app.

You can use the other pane’s “No Split” to keep the other pane.

This means, in my steps you need to use the first pane’s “No Split” feature or it won’t work as expected.