Separators between sections with subdocuments in Compile (Scrivener 3)

I’m hoping I’m just missing a checkbox or something, for this one. I’m using Scrivener 3, and I have a project that I’m going to need to compile regularly during the drafting process (to share with an illustrator). My project structure looks sort of like this:

Chapter [folder]
== Scene [folder]
==== Beat [text]
==== Beat [text]
== Scene [folder]
==== Beat [text]
==== Beat [text]
== Scene [folder]
==== Beat [text]
==== Beat [text]
Chapter [folder]
== Scene [folder]
==== Beat [text]
==== Beat [text]
== Scene [folder]
==== Beat [text]
==== Beat [text]
== Scene [folder]
==== Beat [text]
==== Beat [text]

What I’d like this to compile to (in RTF) would be something like:

Chapter

scene 1 (folder, w/ subdocs)

beat (text)

beat (text)


scene 2 (folder, w/ subdocs)

beat (text)

beat (text)


scene 3 (folder, w/ subdocs)

beat (text)

beat (text)

Chapter

scene 1 (folder, w/ subdocs)

beat (text)

beat (text)


scene 2 (folder, w/ subdocs)

beat (text)

beat (text)


scene 3 (folder, w/ subdocs)

beat (text)

beat (text)

In other words, I want there to be “* * * * *” separators between scenes, but not before the first scene in a chapter, and not after the last scene in a chapter. However, I did a bunch of tests on different section types (as in—folders vs text, with and without subdocuments), in various sequences and configurations, and it looks like the way Scrivener 3 handles separators in compile is that “separators between” only go in between sections of the same type with no subdocuments. So I can get:

Chapter

scene 1 (folder, w/ no subdocs)


scene 2 (folder, w/ no subdocs)


scene 3 (folder, w/ no subdocs)

Chapter

scene 1 (folder, w/ no subdocs)


scene 2 (folder, w/ no subdocs)


scene 3 (folder, w/ no subdocs)

But as soon as the “Scene” sections have subdocuments that get included in compile, the separators between scenes vanish. So the closest I can get to the layout above using compile is by using either a) “separators before” on the Scene layout, which inserts an extra “* * * * " before the first scene in a chapter; or b) the “suffix” pane on the Scene layout, which inserts an extra " * * * *” after the last scene in a chapter.

Yes, I can go through and delete those extra separators by hand (or—more realistically, I’d probably write a Python script to do it for me), but that just seems incredibly silly? This doesn’t strike me as a particularly esoteric thing to want to do. (I mean, I also could add the separator to the top of all relevant not-first sections, which also seems totally ridiculous? Isn’t not doing that the point of compile?) But is there a setting, somewhere, that controls whether or not separators are inserted between successive folders (of one type) with subdocuments (of another type)? Or… another hack for this that I’ve missed in there, somewhere?

(FWIW, I’ve been using Scrivener for something like 10 years, for both fiction and to write a technical masters thesis that ultimately compiled to LaTeX, so I completely get that Scrivener’s not intended for final layout. But because I’m going to have to compile this many many times during the drafting process, I’d like to be able to get the separators working the way I’d like, to reduce the amount of time it takes me to send this to my illustrator every time I have a substantive change.)

Thank you!

All of this is managed through the Separators pane in the Compile Format editor. In addition to the default separators, you can define different ones for specific Section Layouts. See Section 24.4 in the Scrivener 3 manual.

Note that in the layout you describe, the separators “belong” to the “beat” documents, not to the “scene” documents. Also remember that, if necessary, you can define “Beat with Separator” and “Beat without Separator” as different Section Layouts, and make them identical in all other respects.

Katherine