Serial # okay on one Windows comp but "unknown" on other?

I successfully activated my new-today license on a trial version I downloaded to one laptop last October. It is up and running.

I then tried to enter my license on a copy of Scrivener I downloaded yesterday onto a second laptop. After I entered my license number, it first gave me the same “You have 60 days left to activate Scrivener” window, but it was (after a wait) followed by a popup window which stated “Unknown serial number” and advised that I either wait a few minutes for my order to process (I have) or “recheck your serial number.” When I push “okay” on this popup, the program closes.

I’m perfectly happy to “recheck” my serial number (which I take to be an indication that I might have mistyped it?), but I can’t find a way to enter it again. These are the only 2 windows I am capable of getting. I have tried periodically over about 45 minutes and also restarted.

Am I missing some kind of obvious way to re-enter the license, or is there something else going on?

Thank you in advance!

[Edited for clarity.]