SERIOUS BUG REPORT:Display ERROR of Bluetooth Keyboard input method On IOS 10.3.3 & 11.0.1

I am so confused why this serious BUG last such long time and no one reports it. Is that your gays just programing this software but never use it to write any genuine novel or even a short article??I think any one use ipad to write the one will use Bluetooth Keyboard. But the truth is Scrivener with Bluetooth Keyboard cannot input any words at all when you have typed full of an screen page.The input method words list will be hidden and coverd by the downmost input bar. I found this problem when I was writing a long letter with Chinese Characters on IOS 11.0.1. To solve this , I’ve try downgrade my iPad Pro 10.5 inch to IOS 10.3.3 and try beta version of iOS 11.1.0. But the BUG still and even more serious. Anytime you type entire screen page words , the input method choices list will disappear at all. So you cannot continue any words to the article and got to make a new document !
I have report this problem to apple iOS beta feedback. And I don’t is these problem can be fixed by adjust the way downmost input bar display.
Looking for your reply !

Lancoan Aventura

As a first off—and admittedly not that helpful—comment, none of the development and support team use Chinese as one of their working languages, and you are the first one to point this out. No users of other input languages have reported similar problems. Also, I would imagine that where the input selection bar appears on screen is part of Apple’s code. I don’t think KB can have any control over that whatsoever, and there seem to be other serious bugs in Apple’s text system that he has had to work round while waiting for Apple to deal with them. They may well not affect you so much in Chinese.

I do use a small amount of Chinese, but mostly work from Chinese to English, with the Chinese imported into Scrivener on MacOS. Also, I do have an iPad with Scrivener for iOS installed, as well as a Logitech bluetooth keyboard, but only use Scrivener on it a little and haven’t used it for Chinese. I use Chinese in 微信, but those are not long texts and I use the on-screen keyboard for that. I haven’t used the bluetooth keyboard for quite some time.

I will try to see if I get the same result as you, but I am merely a long-term Scrivener user, not a member of the team, so I can only pass on to them what I find, just as you have.

It would also perhaps help if you said which particular iPad you’re using, the bluetooth keyboard you use, and which version of Scrivener for iOS you have installed.


I keep in touch with Jeff through E-mail, I will push the progress here to share with you.

Hi Jeff,
Thanks very much for your concern about this issue.I don’t know wether this problem is attached with device model. I’m using IPad Pro 10.5 inch 256G and Logitech K380 Bluetooth Keyboard.I have made a new project to test duplicate the scene and find out what’s the key factor to this process.As you can see in my new screenshot.Firstly, you must use Chinese input method (You have awoken of this one and my apologize for developer using purely English). Secondly, you must continuously typed about 470 words (number attached with fonts and zoom,I use Body Fomat Presets and 1.2x to show)which displayed by top bar. And any time you reopen the app , the duplication about how much words you have tpyed anew depend on various condition.But if total words is about 500, this number will be not too much.You just need to type more words, as far as the screen page will be moved advanced to next screen , the Auto Page Advance with the words you are typing is the key factor to duplicate the issue. And the pop up disspear is a step by step process as the more words you typed the more disspear until thoroughly fade away…
Have a try please, and tell me about the progress.
Lancoan Aventura

Hi Jeff,
As you can see the Chinese input method pop-up in Apple Pages APP display , the words choice list is on above of the letters you’re typing. But when in Scrivener. The pop-up comes to below. This single different make the problem happen as the downmost bar will display just covered the pop-up.And in the third-party app which don’t have this problem is same. For example , I’ve bought 3 app Bywords , Drafts , IA Writer to test the condition. In Bywords , all is same with Scrivener, you cannot type any more when the screen is full and got to take advance , the pop-up is display on below. But when it comes to IA Writer , all the problem is solved by move pop-up to above when you’re typing in bottom of screen. My screenshots will show you more detail.
I hope the problem cloud be fixed as quickly as possible for I have recommeded Scrivener to many Chinese Background Friends. But they like what I said in first letter , they just keep the app and don’t write any article or novel to found this problem :slight_smile: . I hope when they got start to use it, the problem has been fixed and I will not be blamed for such much dollars waste.
Lancoan Aventura

the way IA Writer and Pages use as you can see in screenshot.

By the way I’m the chairman of an Astronomy Society in University . Your avatar is also our society chat group avatar from NASA :slight_smile:.
Show one picture we shot ago

Although you can see in the screenshot I was using IOS 10.3.3. But that was a test. In fact, all the IOS 10.3.3 11.0.1 11.1.0 have this issue from my test

Hah! This is actually my third astronomical avatar, but the only one I have used on this forum. I’m not an astronomer; I merely go to APOD every day. I think if I had been to a school where the teachers had understood me and fostered my interest in science rather than killing it, I would have become an astronomer or a physicist.



By the way, I’ve never used iAWriter, so know nothing about it, but Pages is no good as a comparison. It seems that Apple use a private text engine for Pages, not the text engine they make available to developers. The same is true of Word and Mellel, both of which use proprietary text engines.

I’m busy for the moment, but will test when I can.


I haven’t yet had time to test this issue, but it’s not out of mind, and the thought struck me that maybe iAWriter is a plain text editor, and if so is using a different text API from the RTF one which Scrivener uses. That might explain the difference in where the character selection bar appears.


IA writer is a markdown editor and don‘t support it might be.But in the other markdown app Byword also has the issues, just little difference in detail, and also pop up will disappear.

And I found bluetooth keyboard has widely influence in text edit.Another editor which use Downmost bar named Handyflowy, as third powerful editor to Workflowy , even could not loading bar. And lead to cannot edit anything under Bluetooth mode , input method will crash. The Downmost bar has many problem across iOS 10 to 11 and different language input.

Finally , the problem solved by using another app that has a better sollution in pop-up problem. Every pages ending with black line above toolbar. So the bar will not hide pop-up anymore.