Session target notification not working in Composition Mode

Hello,
First, thank you very much for the feedback, and sorry for my level of English. I have Mac version 3.0.3, and I always write in Composition Mode. Until two days ago, when I reached the target of words that I had marked, a warning would appear above the Composition Mode. I’ve seen the warning in the notification center of the Mac for two days now, but I can´t see it over the Composition Mode while I’m writing, so it’s impossible to know without quitting Composition Mode if I’ve already written enough, what is a annoyance. Especially since it worked perfectly two days ago, and I do not remember changing any settings!
Do you know what may have happened?
Cheers and thank you again.
I love Scrivener.

Scrivener uses macOS’s standard Notification Center to show notifications about targets, but Notification Center will not show messages when the Dock is hidden for some reason. To work around this, you can do the following.

  1. Go to Scrivener > Preferences…

  2. In the “Behaviors” options, select “Composition Mode” on the left, and change “Hide Dock” to “Automatically hide and show Dock”.

If you do this, putting the mouse to the bottom of the screen will bring up the Dock, and notifications will work.

All the best,
Keith

It works!
Thanks again.