Setting default font

I went to Edit>Options>Appearance>The Font box>General – and all it gives me is option to change either document notes or project notes.

To set your default font for the editor, go to the Editor tab of Options. Adjustments you make there will apply to new documents that you create; you can use the Documents>Convert Formatting to Default Text Style to change existing documents to match the new default. You’ll get a list of options there about what you want to convert, so you could check the top one to change only the font. (You will probably in any case want to check the box to preserve font style so you don’t lose character formatting like underlines and italics–this will be preserved automatically in the future.) You can select multiple documents in the binder and then choose this command to change all your older documents at once.

Please note there’s currently a bug where using the Convert Formatting command on a document with inline images will delete the image, so for documents with images inserted you should just select the text and change it manually via the format menu.

Thank you muchly.

I would suggest a cosmetic change on the page: that pale blue italicized capital “A” on the far left side is what I missed as being the “font” adjustment when I first, intuitively, went there. Maybe it should look more clearly like a button – maybe bright RED would do it :slight_smile: !!

A different issue: I have attached a copy of what the page looks like on my computer. I cannot change the default right margin beyond the existing ruler – 14 cm is obviously not wide enough.

Maybe make an adjustment to the page so that it can be maximized. Or provide a box for numerically setting the margins.

Any other suggestions in the meantime – other than adjusting each new document page?
Scrivener Edit page.doc (427 KB)

:open_mouth:

The right-indent setting for the ruler in Options is a known issue and should get fixed soon. If you don’t adjust the right-indent settings in the Editor tab, by default it actually is “none”–so it will just stick to whatever your margin is, as you’ll see if you make your editor wider or narrower when you’re working in Scrivener. Once you change it, you unfortunately can’t set it back to “none” as you should be able to do by dragging it out to the edge (a bug, obviously), so you’d need to reset to defaults and then reapply your changes there without touching the right-indent marker.

It worked!! Just like you said it would!! You are so smart!!

Thank you for knowing Scrivener – especially in its fallabilities – so thoroughly!!

Glad it worked. Actually since posting that I found a better workaround (as usual, now that it’s too late for you). So for future reference (until the bug is fixed), in the spacing drop-down menu of the format bar in the Editor options, you can select “More…” and bring up further spacing options which also include the indents. You can reset the Right Indent to “0” here and it will correct it back to none, the same as resetting defaults does.

I’m having trouble setting the default font.
In the user manual it says:

Emulating Plain-Text: Users who prefer a plain text appearance may wish to set their
default font and paragraph settings in the “Text Editing” pane of Preferences

I don’t seem to have such a “Text Editing” pane?

In this thread it says “go the Editor tab of Options” I can’t find the Options tab?
It says it is under Edit->Options but I don’t have that either?

I have tried

Preferences->Editor
Preferences->Appearance
Preferences->General
Preferences->Formatting

but nothing seems to stand out as allowing me to change the default font??

Ok, cancel the above as I just found it in
Preferences->Formatting-> press the A button (top left)

  • not sure why it is such a secret but there you go.

Thanks.

Hi Denise,

Sorry you had trouble finding it, but glad you got to it now. The different instructions in this thread apply to the Windows version of Scrivener, not the Mac, since this is the Windows tech forum. :wink: As far as the manual, that does sound like a mistake, as there’s no Text Editing tab in either Mac 2.0 or Windows, so I’ll double-check on that and get it fixed if it’s a lurking typo. Thanks!

er … yes Windows forum - just followed the link after searching for “setting default font”. Still seems unusual to set it via “an A” when other font settings are done via drop down menus?

Anyways found now.