Several Bugs-Footnotes, not saving, and highlighter

I’ve been meaning to pop over here and write these down.

Footnotes:

  1. The insert footnotes button does not work. I have to copy and past old foot notes and replace the text.
  2. The footnotes box won’t allow me to start text after unless I bring a line up from below and add a space between a character. A space alone is not accepted.
  3. Compile RTF margins are all over the place. They’re better than they were, but my text is still cropped mid sentence or the whole sentence is cropped in half. I should be able to adjust the margins in word to fix the issues, but I can’t if the text comes from scriv.

Not Saving
For a long time I’ve thought I changed something only to come back into scriv and find it not changed. Usually small things, like a word spelling or what not. Often the changes are so small- a comma here, a period there- I second guessed whether I had changed them. The other day while I worked on a whole manuscript, I realized that scriv really wasn’t saving all the small edits. Some did get saved but others did not. I haven’t been able to decern the pattern.

Highlighter.

I can’t un-highlight text. For awhile I was able to remove the highlight and click save twice (once did not work) but now, if I want it gone, I have to delete all highlighted text and retype it. This is has held true in the notes box. I’ve had similar issues with strike through in the notes box but not in main text.

A little more related, just trying some things here:

  • Putting a footnote within the first sentence blanks the whole sentence out! To replicate, create a scrivening, and write a first sentence. Place the cursor within the sentence, and use Format Footnote. The whole sentence will disappear. Type, and visibility returns, properly inserting your footnote.

  • A goodie, not to do with footnotes. Write in Scrivener, then go to another window. Click on the Scrivener window to return it – in the Binder area. You go back to Scrivener, but the editor is blank. The problem, actually in or outside of Scrivener, is that clicking on the Binder deselects the current scrivening. I don’t think it should do this - confusing, and you have no state for the editor.

Skipping one more possibility which I think was actually user error, mis-selection on a menu, since I can’t replicate.

Regards,
Clive

Hi M.R.,

Could you explain a little more what’s happening when you use the footnote button to insert a note? I’m not having any issues with this myself and haven’t seen it reported elsewhere, so details would help discover the problem. Does it happen just using the button from the format bar or using the shortcut/menu item as well? There is a bug, which has been fixed for the next beta, where toggling the footnote or annotation will cause the rest of the text in the document to disappear until you continue typing or click with the mouse; this is a display bug, and the text itself is still present. (This is the bug you’re seeing, Clive; it only affects text typed into the editor in Scrivener, not copied in, so you may be seeing only that specific sentence disappear rather than the entire document.)

To end editing a footnote and start writing regular text, you should just need to toggle the footnote off by clicking the button again, typing the shortcut, etc., so my assumption is that the problem you’re running into is due to the toggle not working for you as in the first point and the workaround you’ve had to improvise.

Lee’s been working on the intent issue in compile, so hopefully this will be fixed up for the next beta. If you’re willing to zip your project and send it to support AT literatureandlatte DOT com and give instructions for what and how to compile to see what you’re getting, that would be a great help test out the fix and make sure it’s working to cover this issue. Otherwise a few screenshots of your document (and the ruler settings) in Scrivener and what it looks like when you compile and view it in word could help me set up a sample project to replicate what you’re seeing.

As far as the non-saving bug, Lee’s continued to put in a lot of work going over the code which seems to have almost entirely wiped out the issue, and this is the first report of the type I’ve seen since the 024 beta came out, so any more details you could give here would be incredibly helpful.
1.) What is your operating system?
2.) Is your account admin?
3.) Where are you saving your scrivener project file?
4.) What format is the drive you’re saving the project to?
5.) What is your ‘Save after period of inactivity’ set to in Options>General?
6.) and as much relevant information as you can so that Lee can reproduce the same situation as closely as possible

I know you couldn’t find a pattern, but literally every iota of info you can give on this–how you were working, how long the project was open, whether the computer went to sleep at any point in that time, whether you have a sync or backup tool running; everything–can help pinpoint this.

Finally, the highlighter bug is a known issue, having to do with invisible characters picking up the formatting and not releasing it. Try using just a white highlight over top of the color so it looks clean, or if you don’t have other colored text or highlgihts in the document you need to save, use Documents>Convert Formatting to Default Text Style with everything checked except “Convert font only” and “Preserve font colors”–that should strip the highlight formatting entirely.

Noted. Clicking in a blank area of the binder shouldn’t clear the text loaded in the editor, and clicking in the binder when the focus was not already in the Scrivener window should just switch focus and not register as a click within the binder specifically.

Also, forgot to ask–the project that you’re compiling with the messed up indents, was that created in 024 or earlier? I used to have a reliable way of reproducing this error up through 023 but that’s not working now in new projects from 024, so if you have a step-by-step way to reproduce it in a new project, that’d be great to know.

And in the meanwhile, you may be able to fix the compiled RTF by editing the code in Notepad. I’d make a copy of your compiled document, then open that .rtf in Notepad and search for “\ri”. You should find it with a number following it, e.g. “\ri8640”. Delete each instance of the \ri and the number following it, then save the file and open it again in Word. That should reset all the right indents to the 0 default, and you then can go and use the ruler in Word to adjust any where you need it different.

Thanks for the tips on the highlighter! I was getting frustrated with the color showing up each time I clicked to another scene and back or saving, closing, and reopening. :slight_smile:

Cheers,

Marci

Sorry its taken so long for me to get back to you on this. I was on vaccation. (Saying this feels a little like bragging when you’re working like a fiend on this project. Sending a virtual beer your way.)

So here goes:

“Could you explain a little more what’s happening when you use the footnote button to insert a note?”
I can’t remember if it was 2.0 or 2.1 that it stopped working but I had hopped with the 2.4 download it would work again, however neither the button or the short-keys work for me. I read on something about old parts of previous instals causing trouble. I did my best to delete all scriv files before my last download. I’m not very technical so there might be stuff lurking, but I don’t think that’s the case. I’ve zipped the project and am sending it to you.

As far as the non-saving bug,
1.) What is your operating system? MS Windows XP Professional Version 2002, Service pack 2
2.) Is your account admin? Yes
3.) Where are you saving your scrivener project file? Desktop/Stories folder/(Divides into subfolders based on project type and/or status. Before I had them saved to USB but it was the same main folder and my documents. I moved it to the desk top for quicker access.)
4.) What format is the drive you’re saving the project to? NTFS
5.) What is your ‘Save after period of inactivity’ set to in Options>General? It’s set to save after 2 seconds.
6.) and as much relevant information as you can so that Lee can reproduce the same situation as closely as possible.

After I get a story back from critique group, I go through the document and change the nits. And then again before publication. I also listing to it via TTS software which helps ferret out those words that sound the same but mean different things.(This is just a side note. I use highlighter during these sessions to mark text that doesn’t flow well and it would be really nice if the highlighter had a wand feature allowing the cursor to remain the highlighter until I’m done using it.) Later, when I’d go over the story, I’d see some of the same mistakes and I’d think, “man I thought I changed that.” Mostly, I chalked it up to missing the change, however it happened often enough for me to get suspicious. Fast forward to one sleepless nights among many where I decided to root out my writing habits in a larger document (100,000 words). I worked on the same document for four or five hours, during which I altered things like -(one) to – (two). Because I was going through and doing them all and then going back through and changing other things, I began to notice some of the changes weren’t saving. The way I can duplicate it and know for sure it’s not just my error is to use the document search tool looking for over used words like “has” or “-” and changing it to “–”. But having said that, I still get the “I know I fixed that already,” feeling a thousand times more often than working in Word.