Several crash and bug data could non be written message

OSX: 10.7.3

Bug:

What I do:

  • Compile…
  • Compile for MultiMarkdown --> RTF
  • I got this message:

The data could not be written at the specified location
There was a problem writing to the path ‘/Users/peppe/Desktop/test.rtf’. You may not have the necessary permissions to save to this location - please try saving to a different place.

  • Scrivener sometimes crashes after this message

Notice: if I choose others “Compile for…” options, Scrivener does not have trouble to save the output in the same path, so there’s not a problem of permissions.

I purchased Scrivener at the app store yesterday after 2 days of trial when I thought ok it’s the best.
I start to custom and to play with the UI and it crashed a lot of time, I’m getting disappointed about :slight_smile:
I sent all report.

Some of them it happened when I set the preferences (especially font and colours).
Another one when I clicked “edit label”.

I hope you could consider to improve its stability.

I’ve been using Scrivener off and on since 2007, and I can’t remember ever having had a crash (though my memory is not as good as it used to be) so I’d say the stability is very good. You might try running a cleaning utility, like Onyx, to give the system a spring clean. It’s surprising what accumulates on the hard drive over the years.

Martin.

Hi hybris,

I’m very sorry to see that you’ve gone ahead and given us a lowly two-star rating on the Mac App Store, thus affecting our business, rather than giving us the chance to try to get to the bottom of your problem. We are a small team, and I am the sole developer working on Scrivener for the Mac. Scrivener enjoys a very good reputation for stability (and is certainly not “immature” - it has been going now for several years, and has many thousands of users trusting their long book projects to it) and I work very hard to maintain this reputation, so always hurts somewhat when someone fires off a negative review without even first giving us the opportunity to try to help.

I’m sorry that you have been experiencing crashes, as this is most certainly not the experience I would wish a new customer to have, and hope we can work out what is going on, if you haven’t already claimed a refund from Apple. I’ve looked at the two crash reports you sent, and they are very strange indeed. Your Mac App Store review indicates that you are having crashes when changing labels, and this seems to be what has happened in the crash reports you have sent me, which is different to what you are describing here. I’ve never seen a crash report like this one, and it is very strange - changing labels is something everyone does a lot, and obviously if this was something that afflicted the program normally, we would have tens of thousands of users shouting tat us. So, we need to get to the bottom of that.

One thing I note is that you seem to have a lot of plugins operating on your computer, and it’s possible that one of these could be affecting things. I would first recommend temporarily disabling some of these plugins, to see if doing so stops the crashes. In particular, I would try disabling the Google Notifier plugin and the Journler contextual menus plugin.

Edit: Scratch that. I notice that you have SCRFinderPlugin installed. That is known to cause crashes in many programs. Try uninstalling that. This is from a post on another site regarding a different program being crashed by this plugin:

(This is from: github.com/quicksilver/Quicksilver/issues/619)

Your crash report is almost identical to those sent to the developers of QuickSilver and MacVim by users who had this plugin installed:

groups.google.com/group/blacktre … 596e3d8d89

code.google.com/p/macvim/issues/detail?id=398

And Versions:
groups.google.com/group/versions … 04392d0f4e

And Evernote:
leyton.org/fixing-a-persistent-evernote-crash

Thus, I strongly suspect SCFinderPlugin is the culprit seeing as it is known to crash so many applications. If that doesn’t fix things, though, please follow the instructions below:

  1. Go to System Preferences.

  2. Go to “Users & Groups”.

  3. Create a new user account.

  4. Log into the new user account.

  5. Fire up the Mac App Store and sign in.

  6. Download Scrivener (from “Purchases”).

  7. Try the same things that normally cause a crash for you.

Once you’ve tried this, you can delete the test user account. This will allow us to determine whether or not is something specific on your account that is causing the problem.

Regards,
Keith :frowning:

Hi Keith, forgive me, you’re right.
I’m a developer too and I understand your point of view. But when I experienced all that crashes, I became very disappointed. I would have to edit again my rate… but I decided to not wait, I have been too strict.
I updated my rate from 2 to 3 and I edited the review. And I’m ready to give the rate of 5 the app deserves if I solve my issues.

Thanks, hybris, much appreciated. Please try the above suggestions - I suspect that SCFinderPlugin will be the culprit, but let me know, and if not we can take it from there.
All the best,
Keith

I’m trying to do all what you suggested. I let you know soon.
It’s possible it needs some time before my review appears updated on the store.

Ehi Keith, maybe you caught the culprit.
It seems I’m not experiencing any sudden crash.

The problem of permission about Markdown --> Rtf remains (the problem of permissions concerns only when I choose Markdown -> Rtf) - but it does not crash anymore after the message :slight_smile:

It has not a vital importance to me, anyway that’s the error parsing report:

runtime error: file XSLT/xhtml2rtf.xslt line 322 element param
Unexpected XSLT element ‘param’.
runtime error: file XSLT/xhtml2rtf.xslt line 323 element value-of
Variable ‘newLeft’ has not been declared.
xmlXPathCompiledEval: evaluation failed
runtime error: file XSLT/xhtml2rtf.xslt line 323 element value-of
XPath evaluation returned no result.

If I’ll get any crashes in the next days, the first step will be to look for the help here and to avoid bad reviews until I’m not sure about the source of the trouble.
Of course, I’m going to edit again my review.

Great! I’m glad the crashes seem to have gone away - that SCFinderPlugin seems to cause problems across the board with a number of programs. I’d give it a few days to make sure the crashes have definitely gone, though.

The MultiMarkdown thing is still strange, though. Do other MultiMarkdown exports to work - for instance MultiMarkdown -> HTML)? The MMD->HTML export works in exactly the same way as MMD->RTF so I would expect the same results for both… But what I expect and what happens may be two different things, of course.

Many thanks,
Keith

Yes, I confirm that I have no problem when I choose MMD->HTML. Strange.
But it’s not a great problem.

Thank you a lot for the support.
Giuseppe

If you can save the HTML version to your Desktop without problems, I wonder if you already have a “test.rtf” file on your Desktop, causing the issues. It’s possible through any number of odd circumstances, to not be able to over-write a file that exists.

If there is a test.rtf file in place, try renaming or deleting it and then do the MMD compile from Scrivener.

Another tactic is to try compiling to a different directory (such as your Documents dir).

Hi Robert,
no, I haven’t a file with the same name there. Then the overwrite seems work properly in case I compile again MMD->html
Of course I’ve tried to save it in a different place.

That is very strange, as both use essentially the same code - in fact, they use exactly the same code; the only difference is that they call a different MMD script, so the problem must lie there. Are you running MultiMarkdown 3.0 by any chance?

All the best,
Keith

Found!
I was running MM3.2.
But I was lack of MultiMarkdown-Support-Mac installer.
After I’ve installed I solved the issue with MMD->rtf

fletcherpenney.net/multimarkdown/install/#macosx says:

Advanced
If you want to use XSLT to customize your output, or you want to use MultiMarkdown with Scrivener or TextMate, you should also download and install the MultiMarkdown-Support-Mac installer.

A-ha! That makes sense - Scrivener’s default install is MMD 2.x (we’ll be updating that to MMD 3.x soon), and I believe the RTF support - the scripts required to create the files - changed between versions, so if you didn’t have the 3.x versions of the required files but were otherwise using 3.x, this was obviously the result. We should maybe get something up on our Knowledge Base about that. Hopefully everything’s up and running for you now, though, which is great to know. Let me know if you have any more problems, although hopefully after this rocky start Scrivener will now run smoothly for you. :slight_smile:

All the best,
Keith

Thank you for your updated review! Very much appreciated!
All the best,
Keith