severe slowdown, constant saving

Hello,
All of a sudden a file I have been working with for quite some time (a year) has started given me the Mac spinning wheel overtime I scroll, look at word count, or save. I read previous threads and saw that the timing of autosave may be relevant (default 2 sec) and reset this to 30 which was recommended, but this doesn’t help. This is the first serious glitch I’ve ever encounter in Scrivener. Wondering if others have seen it and possible solutions.
My individual files are modest (2-3k words) although the overall Scriv file is large (4.6 megs). I’m using Sierra 10.12.5 and Scriv 2.8.1.
Thanks for any help. I’m mostly worried this file may be crashing (yes it is backed up, but still worried it’s corrupted).
Thank you.

You must have a lot of words if you end up with 4.6 Mb of words. Or do you by any chance have images in there as well, in the same docs. If you look in this thread (yes, it’s in the Windows part) you will get some suggestions.

https://forum.literatureandlatte.com/t/scrivener-periodically-may-be-each-10-seconds-or-so-freezes-all-the-time/37346/1

My project is over 5MB (no images) but I don’t see this behaviour - 2011 iMac running 10.9.5, 12GB RAM.

The questions I would ask are:

  1. do you have many other applications open when you see this?
  2. when did you last reboot?
  3. when did you last close the project to force a backup, or quit Scrivener?
  4. have you tried to reinstall Scrivener?

Thanks. I don’t think the size of the overall file is huge for a book manuscript. The individual files are all in 2-4k word range. Whether I am in a modest or larger individual file, doesn’t seem to matter.

  1. I do have other applications open, but have tried closing them and it is still slow, seems to be independent of number open.
  2. rebooted this morning, and have tried rebooting.
  3. quit Scriv and reopened multiple times.
  4. Have not tried reinstalling but will try and report.

I’m resurrecting this post in the hope that someone else has suggestions on how to fix it.

I think I tried everything here (and in the referenced Windows thread) but it’s still lagging with the beach ball – except the auto save which didn’t seem to work for anyone.

If I revert to an earlier version, it works. Also, strangely enough, if I open the earlier version, leave it open, then open the later version that does not work by itself, it seems to work. Odd.

I’m still testing this. It may be a workaround but it’s not very satisfying.

D

Are you running any third party backup or synchronization software? I once helped a user whose automatic backup software was attempting to capture every. single. Scrivener save point. Every few minutes she would pause for a few seconds, Scrivener would save, and the backup software would kick in.

Katherine