In the short story template the <$fullname> once compiled shows my full name but it is not adding my last name to the upper right hand corner of each page instead of, “last name / title / page#” it is only showing " / title / page#". How can I fix this? &tanks+

In your Mac’s “Contacts” application, try editing your “me” contact. Is your “last name” field filled out, or do you have your full name all in the “first name” field?

Thanks for you reply RG, I looked in my contacts for the “me” contact and the closest thing I could find where two contacts, one for my full name, first and last, in the proper boxes and another that was just my first name with a silhouette icon to it’s right. On that contact I filled the last name box added my last name to that contact, and re-compiled to no avail. Still only title and pagination in every upper right hand corner.

Moderator note: moved to Mac technical support.

To find the correct card, from Contacts use the Card/Go To My Card menu command.

Thank you AV, it was the contact of the two with the silhouette icon to it’s right, ezpz. The contact does have both first and last name in the proper boxes but still is not appending to the title and pagination in the upper right hand corners of any compiled page.

Okay, to rule out whether the card is fine, try copying and pasting the following into the first page of your manuscript, then compile, and see if your name appears in the text:

<$fullname> - <$surname>, <$forename>

If they work there, then we can see about whether there is something off with the headers.

Good Morning AV, I tried the test and it gave me this:

Tim Goodwillie - ,

CODE: (in black)
SELECT ALL (in hyperlink blue)
Tim Goodwillie - , (in green the color of the code)

Thanks (emoticon with shrugging shoulders)

That’s strange, the first code should just be combining the data from the pair of codes on the right that are producing empty results. At any rate it does seem to be a problem with the link to the card itself. Try this: create a new contact card, fill out the name and whatever else you want, and then use the Card/Make This My Card command. You should see the little “silhouette” icon move to the new one. Now try compiling again and see if it works.

I created a new card a new card, made it “my card” which gave it the silhouette. Re-compiled and nyet, same result as before.

Tim Goodwillie - ,

Okay, let’s try this, it’s possible to override what is taken from the card on a per-project bases. Use the Project/Meta-Data Settings… command, and click on the “Project Properties” tab if necessary. Now, if everything is working correctly, you should see your name in the last three fields in grey text. If you don’t see some iteration of your name in a field, try clicking into it, pressing Cmd-A and ‘delete’ to remove whatever is there. Does it show up now?

If not, just type it in. I’m not sure why it’s not working with the card correctly, but you should be able to manually enter that information here and it will show up in the headers.

What version of OS X / Scrivener are you running by the way?

Good Morning, I am running osx 10.10.1 and Scrivener 2.6. In Project/Meta-Data Settings/Project properties the top three boxes were filled, the two title boxes and the fullname box, the surname and forename boxes were empty. I filled them and compiled and it plugged my last name in to the header of each page. Fixed, but sad it is not doing it automatically. Thanks for your help+

Do you have any other programs that make use of the Contacts list to insert personal information? You can check in the Security & Privacy System Preference pane, under “Contacts”. Locate a familiar program and try doing something that should propagate your name (that isn’t already stored in its preferences, some programs just use your address book once, to set themselves up).

Tah-Dah! That was it Scrivener was unchecked in the contacts of the Security & Privacy System Preference pane. Checked it and poof I am in the header now. Thanks sooo+

All right! Good to know that it still gets the full name even when that condition is set—it must get it from your account name. I always assumed it was taken from the card as well though, which is why I didn’t think to check for that setting.