shortcut for Convert > to Folder

Hi,

I lost my shortcut shift ctrl cmd F for “Convert to Folder” from Scriv2 and can’t find what’s the matter.

It would be great to hear what the exact shortcut is so I can check things out using the correct command.

(edit: if I convert a file once using the mouse and menu, the toggle convert to file/folder works. so the command is probably correct.)

and: I have once used Karabiner to be able to use right option + arrows to browse a pdf, but uninstalled it. could that have messed up keys?)

Does a new shortcut work right away or do i need to quit Scrivener, close Systems Prefs, or reboot?

(I found these threads and can’t quite apply this to my shortcut - does it need an ellipsis, do I need to make two shortcuts, do I need to redefine sth else? I don’t want to redefine Find.
https://forum.literatureandlatte.com/t/lost-keyboard-shortcut/38722/1

I also booted in safe mode, made a new user, deleted all shortcuts and made them new and such according to here: discussions.apple.com/thread/7893765 )

thanks!

The full path to the command, in System Preference format, is “Documents->Convert->to Folder” and “to File”. So “Convert to Folder” would never work. I would expect “to Folder” to work though.

thanks for replying to my very confusing post. to Folder works as the to File/Folder toggle, Convert to Folder does not. Changes in SysPrefs work instantly, no need to quit anything. Each time I open Scrivener I need to trigger it once via menu though before it works, but that’s a minor thing.

Yeah, some menu types that alter themselves dynamically do not pick up SysPref shortcuts when the menu system is initialised, until you look at the menu directly. One of my favourite overrides is Navigate ▸ Collections ▸ Binder, so I can get out of searches and collections without using the mouse. But that’s another one you have to look at first.

I’ve found third-party tools such as BetterTouchTool and Keyboard Maestro do not always have this same limitation, for whatever reason. There may be some free ones as well.

hm, getting out of Find withoung mouse sounds useful. I named ctrl option cmd O Binder for Navigate->Collections->Binder but when I type it nothing happens.

BTT I have had since ages but never got around to really checking it out - I can select Scrivener and enter a shortcut but cannot find how to assign a menu item. (I don’t have a touch bar, but the last nonretina MBP, ~2012.)

Could you please describe in more detail how you are using this?

How are you entering it in System Preferences? I tested your suggestion and it works immediately as soon as I entered it.

Here is how to set up a shortcut in BTT:

  1. Go to Scrivener’s section and make sure the “Keyboard” category is selected along the top.
  2. Click the +Add New Shortcut or Key Sequence button below the main list.
  3. In the “Shortcut” capture box, press the keys you wish to use.
  4. Use the dropdown menu under Trigger Predefined Action, and I just type in “menu” to search for the “Trigger Menubar Menu-Item” action.
  5. This will bring up a window with a bunch of help text for how to address menu commands.

In you case, you could use “Documents;Convert;to Folder”. But, as you might have noticed from the help text, BTT has some neat tricks for making things a little easier. You could actually set this up as a toggle, so that the same shortcut triggers both the “to Folder” and “to File” command, like this: “Documents;Convert;to Folder||to File” (that’s a double pipe symbol in between the two menu variants).

Once I’ve done that once, I tend to copy and paste in the main shortcut list rather than go through all of the steps for each one.

sorry for the break, deadline, barely slept :slight_smile: like this:

I did this with Navigate;Collections;Binder and it worked. not sure why it didn’t with lunk’s.

the SysPrefs command also worked as a toggle with just the “to Folder” command. but I set it up anyway with BTT so I don’t need to trigger the command by hand each time I open. very useful, thanks!