Shortcut Win+N+V to move focus doesn't work when focus is in binder

If the focus is in the left or right editor, the keystrokes Alt+N,V open the “Move focus to …” sub-menu. But if the focus is in the Binder, nothing happens when the V key is pressed after Alt+N. Other shortcuts I tested work with focus in the binder.

Perhaps this has to do with the fact that, when the focus is in the left or right editor, the first Navigation menu item is “Reveal in Binder” which also uses “V” as the shortcut? That option is grayed out when the focus is in the binder.

I think you might be using the wrong shortcut for this…
Try this one instead : Win+Alt+E → [EDIT]Might not be the default for it tho. It is possible that at some point I customized it. Still yet, you can easily see what shortcut to actually use from your own menus. Use my below screenshots as reference. [/EDIT]
As you can see from my screenshots, depending on where the focus is to begin with, it does both (focus to binder / focus to editor).



. . . . . .
And by the way, Alt + are not really shortcuts.
But it seems that unlike for you, Alt+N+V works both ways for me.
Alt+N+V+E+Enter when starting with focus on the binder.
Alt+N+V+B+Enter when starting with focus on the editor.
(Phew, quite a time saver, isn’t it ? :stuck_out_tongue: )

Thanks for your reply! Point taken that the Alt+ are not really shortcuts in the software, they’re Windows functions.

Win+Alt+E does work as a way to cycle through the Binder, Left Editor, and Right Editor—that used to be Ctrl+Tab, which I found much more convenient.

However, on both my desktop and laptop, if the focus is in the binder, pressing Alt+N drops down the Navigation menu, but after that pressing V has no effect. If the focus is in one of the editors it works correctly.

The default shortcuts of Win+[, Win+] , and Shift+Win+B do work to go to the left and right editors and the binder regardless of where the focus is.

What I would like to do is set up an AutoHotKey script that I would then use in Dragon to navigate to the left and right editors and binder by voice. But so far I haven’t found a way to do that, since the only methods for moving to the left and right editors that work for me when the focus is in the binder involve the Windows Key, and triggering Windows Key plus keystrokes can get problematic when trying to use other programs to send those key combinations.

Can’t you simply then customize the shortcut you need to be not using the Win key ?
Shortcuts are customizable under options \ keyboard.

Discovery after writing what’s below: the problem arises when using the Alt key in the shortcuts. When I set the shortcuts to just use Ctrl+ some key, they work fine. I’ll go with that solution, but I do think this represents a bug in the software.

Written before the discovery:

Yes, I tried that, but for some reason those shortcuts just don’t work for me. If the focus is in the binder, then the shortcuts set to move focus to the right or left editors work fine. But if the focus is in either of the editors, pressing the shortcut to the other editor or to the binder doesn’t work.

E.g., if the shortcut for the right editor is Ctrl+Alt+p, when the focus is in the Binder that shortcut moves focus to the right editor. But if the focus is in the left editor, it just types the letter p. Likewise for a shortcut to move focus to the left editor or to the binder.

Initially I thought maybe it’s just a problem with my install, but since it happens on my laptop as well as my desktop I’m inclined to think it’s something quirky inside Scrivener and how it’s handling these shortcuts.

Happy to try anything else if you have any ideas. Thanks so much for your suggestions!

Another alternative would be to switch to the version 1 shortcuts. Look under options, keyboard, import.

Someone else can present the pro’s and con’s of switching. My use of shortcuts is limited and I rarely have two editor windows open.

Thanks @tswalker! I hadn’t realized the option is there to switch back version 1 shortcuts. I prefer to keep myself as current as possible with the latest releases, and my comment above about the Alt keys has shown me a way to get this working with the current version shortcuts. If that hadn’t worked I might have switched back to version 1, per your suggestion.