Show Project Targets Not Working

Hello,
The new Mac version 2.0.5 is fabulous, except that the very handy Project Targets function seems to have malfunctioned. I set an overall project target with a deadline to guide my work. For the first day or two everything worked fine, but now when I click Project–>Show Project Targets (or use the keyboard shortcut), no window appears. The Project Targets Window does not appear at all anywhere within the application. It functions fine with other smaller projects but not with the primary project I’m working on, which, unlike the smaller projects, has a number of research documents, character notes, etc. in its binder. Could this be a bug? Or is there a solution or setting I need to be aware of? I am using Mac OS X 10.4.11.

Many thanks,
Katherine

Hi,

This does sound like a bug, yes - it sounds as though an error might be getting thrown somewhere. Could you please try the following?

  1. Fire up Scrivener with the affected project and go to open Project Targets, to ensure that the bug gets triggered.

  2. Assuming the bug occurred and it didn’t open, go to the Finder and look in ~/Library/Application Support/Scrivener/Logs (where the tilde represents your home folder). There should be a file entitled Console.log there.

  3. Either attach the Console.log file to your reply (you can use “Upload attachment” below the text box in which you type your reply) or open it in a plain text editor and copy and paste the contents into your reply.

This should show me the exact error that is getting triggered.

Also, if the affected project isn’t too big, could you please zip it up and send it to kb-tech-support@literatureandlatte.com? I’ll take a look.

Thanks,
Keith

Thank you, Keith. Attached is the console log from my most recent session in which I attempted to display the Project Targets window. I got the same result as before. Any help is appreciated. In the mean time, I’ll attempt to zip my entire project.

Regards,
Katherine

Did you forget to attach it? Maybe you forgot to click on the “Add the file” button after choosing it?
Thanks,
Keith

My apologies. I thought I attached it, but now see that I received an error message stating “The extension .log is not allowed.” So below is the text from the Console log file. Thank you.

2011-04-17 19:53:27.518 Scrivener[252] *** -[NSCFDate dateByAddingTimeInterval:]: selector not recognized [self = 0x6a83220]
2011-04-17 19:53:27.657 Scrivener[252] *** -[NSCFDate dateByAddingTimeInterval:]: selector not recognized [self = 0x6a83220]
2011-04-17 19:53:33.254 Scrivener[252] *** -[NSCFDate dateByAddingTimeInterval:]: selector not recognized [self = 0x68e19e0]
2011-04-17 19:53:33.255 Scrivener[252] Exception raised during posting of notification. Ignored. exception: *** -[NSCFDate dateByAddingTimeInterval:]: selector not recognized [self = 0x68e19e0]

Mac OS X Version 10.4.11 (Build 8S165)
2011-04-17 19:15:33 -0400
2011-04-17 19:15:37.736 SystemUIServer[213] lang is:en
2011-04-17 19:15:37.812 SoftwareUpdateCheck[216] Checking for updates
Workaround Bonjour: Unknown error: 0
2011-04-17 19:15:58.752 GrowlHelperApp[220] CFLog (0):
CFPropertyListCreateFromXMLData(): plist parse failed; the data is not proper UTF-8. The file name for this data could be:
/Users/katherineswink/Library/Cookies/Cookies.plist
The parser will retry as in 10.2, but the problem should be corrected in the plist.
2011-04-17 19:52:50.960 GrowlHelperApp[220] Auto-discovered registration ticket in Scrivener (located at /Applications/Scrivener.app)

Ouch! It seems that the new deadline code I added uses a Snow Leopard-only method, so it is throwing an exception on Tiger and Leopard. I had completely missed that the bit of code I used was 10.6-only, sorry about that (one of the joys of backwards-compatibility).

I hope I’ve just fixed it - please download the latest 2.0.5.5 beta from this thread and let me know if it fixes it for you:

https://forum.literatureandlatte.com/t/scrivener-2-x-update-betas-download-here/11262/1

Thanks and all the best,
Keith

It worked! :smiley: Thank you so much for the quick resolution, Keith! One of these days I may upgrade to Snow Leopard, but likely not until my 7-year-old PowerBook gives up the ghost. I appreciate you taking the time to make this feature compatible with the older operating system.

Many thanks,
Katherine

Glad that fixed it! Thanks for bringing it to my attention.
All the best,
Keith