Show Project Targets Shortcut Not Working

Hi Keith et al,

I have a tiny issue that may be a bug. It’s not causing any problems, just a mild annoyance really.

Through Mac’s Application Shortcuts in Preferences I have assigned the keystroke cmd-alt-ctrl T to Show Project Targets (convoluted I know but it’s because I use the same key pattern with C for the compose window and P for the scratch pad).

The thing is, on first opening Scrivener when the Project Targets window hasn’t been opened as yet, they keystroke doesn’t work.

To resolve it I have to click on the menu options to get the window open and once I have done this, the keystroke will then work for the remainder of the time Scrivener stays open. i.e. my shortcut successfully opens and closes the targets window.

Scrivener: 2.1 (14118)
Mac OS X: 10.6.8
The console log is empty.

As I say, small issue. But it is nice to open my project hit cmd-alt-ctrl C T P and get writing.

On a side note, I hit 70,000 words yesterday and I honestly don’t think I could have handled this volume without the seamlessly elegant features of Scrivener. My progress bar is a strange colour, somewhere between orange and green and DAMN that feels good!! I talk about it so much my husband thinks I’m having a love affair with your software. :smiling_imp:

Thanks so much.


Hi Gilly,

Okay, this is an easy fix on my end and it’s easy to work around your end too. Basically, “Show Project Targets” used to be called “Project Targets…”. Because it switches between “Show Project Targets” and “Hide Project Targets”, that’s all handled in code, but I never updated the core interface file with the new name - that still has “Project Targets…” You never see that, because the menu title gets updated as soon as it’s opened (that’s how menu title updates work), but it means that until the menu is opened, behind the scenes its title is “Project Targets…”

So, on my end, I have changed the interface file to say “Show Project Targets”, so that the shortcut will in future work even on first opening the project.

On your end, you can work around this in the meantime by adding to System Preferences exactly the same keyboard shortcut for “Project Targets…”.

Congratulations on hitting 70,000 words! I’m jealous!

Thanks and all the best,

Hi Keith,

Damn you’re fast!

But, unfortunately the workaround doesn’t work. My Application Shortcuts now look like this, with the new Project Targets shortcut added.

But it still doesn’t open the window. I even restarted Scrivener, but no joy.

I can work around with the menu options until the next release. Unless there’s a beta I can get my mitts on?

Thanks! 40,000 to go! Deadline Christmas Eve for the first draft … I’ll be on champagne that night!!


You forgot the ellipsis - it has to be “Project Targets…”, not “Project Targets”.

All the best,

Ah yes, that works!!

LOL, LIGHTBULB!! Silly me, I thought your ellipses meant ‘blah blah blah’ as in, “add Project Targets and the same shortcut blah blah blah, you know what to do”.

To be fair, you did put it in speech marks, I should have been a bit more on the ball there!!!

Anyway … it’s working like a dream!

Thanks so much Keith.

Have a good weekend