Simple question: "Text Editing" settings for MD?

Starting to use Markdown (not MMD yet…) in Scrivener 2, right.

On his page http://fletcherpenney.net/mmd-old/using_multimarkdown_with_scriv/, F. Penny wrote:

.

I’ve been trying to modify Scrivener’s “Text Editing” settings accordingly so that they apply to one Scrivener Project since I’d rather keep the option of using Scrivener both with MD and the “traditional” way.

But I’m not sure I got the right settings as suggested by F. Penny. Please check screenshot below…

Thanks.
Scrivener.jpg

I like turning off indent and paragraph spacing as well. In Markdown you’ll want to know when something is really tabbed as that means code or verse block; and since you need an empty line between each paragraph, normal paragraph spacing ends up pushing paragraphs too far apart for my taste. Fixed width is nice if you want to keep things looking “tidy”, especially indented bullet lists, definition lists, and tables—and to my taste, I just usually tend to drift back to fixed width fonts. I’ll experiment with others from time to time, though.

Anyway, your settings look fine to me. This pane doesn’t preview paragraph spacing, but so long as you left that default, it should be 0.

Hi Amber,

Thanks for your reply and good advice :slight_smile:

I put the cursor to the far left so that indenting seems to be turned off now and I selected Lucida Sans Typewriter which is monospace if I’m not mistaken.

As for the rest I’m not sure how I can set the following (couldn’t find it in Scrivener Manual):

  • turning off paragraph spacing
  • fixed width

Thanks.

Paragraph spacing is accessed in the little format bar, here, and in the main editor, the large format bar. It’s under the line spacing drop-down button, but you have to select “Other” from the menu to get into the advanced spacing interface. But like I say, it should already be ‘0’ by default.