Simplenote Not working properly the last few days

I have a Scrivener/Simplenote problem: If I edit a Simplenote on my iPad, it shows up on the website, but Scriviner, when syncing, claims the scene is unchanged and thus unnecessary to synch. Scriviner does synch TO Simplenote, but does not synch FROM Simplenote. Does anyone know how to remedy this?

I checked, but SImplenote and the iPad work fine - if I change something on the iPad, the note on the website is changed, and if I change something on the website, it changes on the iPad. If I sync with Scrivener, it won’t retrieve the edited note. If I change the note in Scrivener and sync, the file on the iPad is changed to the one on Scrivener, but not the other way around.

I have exactly the same problem as Amsterdam Assassin. Started this morning. I’m on Mac (Snow Leopard) and iPad.

Ran some tests, and found that it doesn’t matter if the synced text is a straightforward text file, a folder text, or a text file that was originally empty but now has something typed in from the iPad. I haven’t changed anything about my setup, and all was well yesterday.

Moderator note: Split to its own topic. Please start new threads for new issues in the tech support and bug reporting areas.

Amber V

OK. Before I got the chance to figure out and attempt your technical solutions, sync came up with yesterday’s changes today, so it’s now registering what’s on the server. But before syncing, I checked through the SimpleNote end because of a warning of ‘duplications’ from Scrivener. I found that, unfortunately, some lengthy work has been lost. If I wanted to backup everything I write in Simplenote before synching, I’d just use Writer instead, but I haven’t because the slow workflow would defeat the object of using Simplenote. However, in view of inexplicably lost data, I’m switching apps. Thanks for your help anyway.

JAL: Sorry, I’m a bit confused on what technical solutions I proposed that you are referring to. I hadn’t actually yet commented on this problem, and had only stated that the thread had been forked out from the other issue because it is a different problem.

You state you lost data, that’s very rare, unless you deliberately disable the snapshot protection feature. Have you checked your snapshots for conflict resolution?

So, addressing AmsterdamAssassin, there should be a solution to this problem you are encountering, because I myself am having no problems with the procedure you describe. I can edit items on the web site, run sync in Scrivener, and they’ll be downloaded and updated in the Scrivener software. It would be helpful to know what operating system version you are using, as well as the Scrivener version. Is you iPad up to date, and what generation is it? As well as these details, can you provide a list of steps, preferably starting with a new blank test project (to reduce the complexity of the problem), that will allow me to see where the bug is?

Thanks in advance.


Your suggestion was to check the routing, and that’s what I didn’t get to.

I’m reluctant to generate test data because a) the problem has occured once after two months of use - i.e. it’s not regular, and b) a long time spent on technical problems is a long time away from writing. I appreciate your willingness to look into even potentially small bugs, and know it can be frustrating at your end without sample data.

Nevertheless, I fixed the problem. I found from my Dropbox backups that the missing text had never reached Scrivener. There was no sign of it in Simplenote’s version history either. You’d think that this combination of backing up would cover all eventualities, and in fact, it did, though in an unexpected way. When I took the plunge and did the sync that had a ‘duplicates’ warning, the missing text came into Scrivener. It had to have come from somewhere, and when I looked in Simplenote on the web, it was in the trash for whatever reason. So I managed to get parity by deleting the duplicates I didn’t want, and synching the ones I did from Scrivener. Of course, you can feel secure once anything’s in Scrivener because of the pre-synching snapshots.

I didn’t do anything differently to cause a file disappearance, and certainly didn’t put the missing file into the trash, so there’s no procedure to reconstruct for you. However, and I don’t know if it’s related, but I found that one of my files had a — instead of a – beneath its title in Simplenote. A few days ago, I recall that the cursor on my iPad jumped (which sometimes happens in iOS) and caused me to delete a ‘-’ beneath the title of a file. I then added one back in, conscious that the text at the top has to strictly follow a format to enable synching. It turns out that the ‘-’ wasn’t deleted at all, so the one I added turned out to be superfluous, making it — instead of --. Could the extra dash have caused havoc with my synching?

Apart from this, I don’t know what happened. I’ll go back to using Simplenote again, keeping a careful eye on things, because the workflow is great.

This mishap aside, I have to congratulate you all for a joyous application. I use Scrivener with DEVONthink, Sente, and Simplenote, and I enjoy ths combination so much that I devised and run an annual workshop for postgrad researchers. Simplenote’s very good for concentrating on fragments of writing away from the overview. I will keep a closer eye on the synching from now on though.

So I take it from your description that you are using Dropbox in conjunction with Simplenote via a premium account? I’m actually not as familiar with the mechanics of that, but it sounds like changes were made to the Dropbox copy and never got uploaded to Simplenote? Well, that would explain why Scrivener, going through Sn, was clueless. It’s odd that it never went up to Sn though in the first place. I’m not sure what the deal is there. Maybe your iPad was offline and stuff didn’t update when it should have at the next online opportunity?

That’s quite all right—do check Scrivener for the triple-hyphen pattern though as its probably in the document. Seeing as how it was no longer the double-hyphen, basically all that would happen after syncing is that you would end up with a file on the Sn server that looks like:

[code]Name of Document (Stuff [23])

And now we start the document.[/code]

And in Scrivener you would get the ‘—’ at the top of the document in question. So it’s something you probably need to fix, but it’s not a fatal error. The only thing you want to avoid messing with is the parenthetical coding that links it to a project resource, in the title line.

But yes, I do agree with your final assessment: it’s a good idea to make sure sync did what you think it should have done. We present that yellow collection post-sync as a form of subtle encouragement to sit down and audit the updates immediately.

Thanks for the kind words!

Thanks AmberV.

I think we have crossed wires because I only use Dropbox for backups. My problem was with Simplenote. It looks like there’s server problems at their end. I lost new work last night, and someone else has had problems. See this: … g-deleted-

I’m at the stage with my manuscript (60K words) now where it would probably be better to switch entirely to Scrivener now. Looking forward to your iPad version.

Thanks for the link. Things do seem to be a little less reliable right now for whatever reason. We had a number of support issues all crop up at once, describing similar symptoms, and they all seemed to be originating with issues on the server and potentially the iPad applet. I did all of my testing using their website during this period of time and never had any troubles with that, save for one time there was a little lag after the file had saved on the web site and when Scrivener was able to detect changes with the server on sync.

At any rate, hopefully that clears up soon. I think it might already be, for there hasn’t been any new reports for a few days now.

My SimpleNote sync started working again not long after my previous message, but now it buggered up again.

FYI, I have Scrivener 2.2 for Mac, OSX 10.8.1, and use an iPad 2 with iOs 5.1.1. I’ve used this combo for a while and the sync always worked. I didn’t change anything, I don’t make notes in SimpleNote, but I only edit the text in scenes I synced to Simplenote. If I go to the next scene, I put a @ in the note I’m working on and wait until it’s uploaded in Scrivener before I split the scene into the next scene.
The malfunction is a riddle to me.
I synced again, deselecting all scenes first and that deleted all the notes. Then I selected some scenes from my work in progress, synced with SimpleNote and presto, they’re on my iPad and the SimpleNoteApp website. I edit a note in SimpleNote on the iPad, the edit is registered on the SimpleNote website, but when I sync with Scrivener the sync wizard says the flagged scene isn’t edited and doesn’t need to be updated.

So, I’m pretty much out of options. The only thing I can do is copy+paste the text of the note from the SimpleNote website into Scrivener manually. Help please?

As before, the situation righted itself again, and the sync is now working properly again.

I checked, and, as before, this issue cropped up in the weekend and remedied itself the Monday after the weekend, so I think it only occurs on weekends…

I’m still pretty sure this is a periodic problem with their servers. It appears to be returning invalid information via its API from time to time and there isn’t anything third-party tools can do to get around that. If the server says that file X was modified yesterday when it was in fact modified ten minutes ago, and all Scrivener can do to determine that modification date is the server saying yesterday—there is just no way around that. I could be wrong—maybe there is some extremely rare condition that is causing Scrivener’s mathematics to foul up and its inverting datestamps or something, but given that I’ve never seen any reproducible bug for something like that, and given how very easy it is to compare to dates (and thus hard to introduce a bug into), I’m inclined toward the more basic answer: the date that Scrivener is provided with is invalid.

When it happens, give it a few minutes and try again. Like I said before, I had this happen once where I made a change on the website, tried syncing about 30 seconds later, and the API returned the old date stamp to Scrivener so it was unaware of the changes. I waited about 60 seconds, tried again and it worked.

Well, I tried it to and fro, but the salient detail is that both times it happened in the weekend - so next time this screw up happens, I’ll just hand copy the edited scenes into Scrivener and wait until the weekend is over…

Hmm, it could be Simplenote was doing updates over the weekend and you got caught in the middle both times. It would make sense to make server changes over the weekend for something like this, as I imagine most people use software like this during the work week.