Simplenote Sync Error 2001

I just had my MacBook Pro replaced with a brand new one, and migrated over. Everything’s in working order with Scrivener except in trying to sync with Simplenote.

I keep getting to where it tries syncing the files I’ve ticked, and it says it’s syncing 1 of however many, and then stops and gives me error code 2001.

Anyone experience this before? I don’t know if it’s related to changing computers but I migrated everything over so shouldn’t be. I don’t know what else to try… Suggestions most welcome!

Hmm, guessing it could be Simplenote’s servers because I’m really struggling to get things working on my account on Simplenote’s website.

Bummer. Am about to run out the door with my iPad, hoping to get some writing done. Oh well!

I’ve been having the same problems for months, and I paid the $20!

I love using Simplenote with Scrivener to work on my iPhone and iPad, but now Im stuck.

Simplenote Premium support has just stopped responding to any support requests.

Scrivener folks, if their support and function is this spotty, you might consider removing them from your list of supported apps. Otherwise you have a lot of frustrated Scrivener consumers. If it works, endorse it, if it doesn’t, cut all ties to it.

Make sense?

Love your software, not so happy with your partners…

Wow, I’m glad I read your post, hughblong. I was about to pay for the Premium Simplenote account thinking this might HELP matters, but I guess not!

Now I’m commuting an hour each day and love using my iPad to work on my Scrivener files but every night I get home and try to sync, and while the Simplenote server shows the updated files are there, they don’t show as red arrows in Scrivener in order to sync - sometimes they do, but it might take 12 hours.

@Simplenoteapp on Twitter has announced over the past week “problems with 3rd party apps” as though this is just a current issue, but it’s been going on for me since early September.

Scrivener, would be so awesome if you were able to recommend/work with another app that could do the same thing - only reliably so!

Agree that it would be best to cut ties if the Simplenote developers can’t keep their app working. It’s very frustrating to rely on this for edits to a novel and have them either disappear, or then have to cut and paste from the server back into Scrivener and then reformat every single day!

Also, noticed that the “Sync” button that you can customise to put in your Scrivener toolbar is now greyed out and never lets me use it anymore. Random, but wondering why.

I also had random server problems with Simplenote, but only when using ResophNotes on Windows, but not with nvALT on my MacBook.

BTW, they got that nailed down to an old server / API problem, and a Resophnotes update solved the problem (for me).

Perhaps Scrivener also uses the old API and old database and has to be updated … Keith?

PS: “Banning” and “cutting ties” is seldom a good strategy regarding software development :slight_smile:.

The SimpleNote servers have been somewhat unreliable for about a month or so. We’ve seen a number of support requests regarding failed synchronisation and every one of them turned out to be issues with the server either not being up to date at all with their own iPad applet, or the server wasn’t properly reporting the latest version of the file to Scrivener when it requested that information. Unfortunately there isn’t much we can do about any of this, as the reliability of Scrivener’s routines require the server to be accurate and up to date.

Alternative is to use the folder sync feature with Dropbox and a text editor on the iPad that is capable of syncing with Dropbox. A lot of people prefer this approach in general because you are no longer limited to using one applet on the iPad. There are many text editors out these days with a variety of powerful features that can talk with Dropbox.

… is there any solution to this problem yet - I experienced the same issue but with error code 401 - any advice?

Have you contacted Simplenote support yet? As best as we can determine these are localised problems between various Internet uplinks and the Simplenote servers, rather than anything universal. We have yet to reproduce any of these errors on our systems, and we are all scattered around the world, too.

Synchronization with Simplenote is also failing for me, error 401. It has never worked for me. I just recently discovered the feature after installing the Scrivener 2.5 update and was trying to take advantage of the feature. Here is some additional information:

Synchronization works without error — if I do not choose any files from the Scrivener project. That is, files on the Simplenote server (unrelated to Scrivener or the project) can be imported. I can see those files later in the Scrivener project. It is only when I choose one (or more) documents from the Scrivener project that the error occurs. It looks to me like there is a problem on the Scrivener side.

Testing was done with a new Scrivener project, created from the Non-Fiction template. One topic modified with just a couple sentences. That topic chosen for sync.

Login to Simplenote was verified on iOS and OS X using the Simplenote apps.

Little Snitch is in use, but should not be a problem. Prompts were displayed for outgoing access and I approved them. I also reviewed rules created in Little Snitch.

• OS X 10.8.5
• Scrivener 2.5
• Little Snitch 3.0

Are you experiencing a condition where sync does in fact actually work, but you get a warning anyway? That’s what I’ve seen from other cases. People will get a 401 error upon sync conclusion, but everything works anyway. The error just has to be dismissed and essentially ignored.

As for myself, I’m using the same exact setup you are, and ran the same exact test you described, including Little Snitch, and I’ve never seen this problem, which is why I suggested contacting Simplenote support, since it doesn’t seem to be a universal issue with Scrivener specifically. It could still be a partial problem with Scrivener, of course, but exactly what triggers it, if so, remains elusive.

Thanks for the fast reply, AmberV.

No, documents are never successfully copied from Scrivener to Simplenote. Documents already on Simplenote (unrelated to Scrivener) do get synchronized down to the Scrivener project, though. So I know that the connection is made and some files are being synchronized, just not the ones I need.

I deleted all Simplenote files in the Scrivener project. I started the sync process in Scrivener. I chose one document (text only) from the Scrivener project to sync to Simplenote. In the next screen of the sync process, I chose one file from Simplenote to sync to the Scrivener project. After starting the sync: the 401 error occurs, the file going to Simplenote didn’t, and the file coming from Simplenote did. The results were verified both in Scrivener and in the Simplenote client Mac app.

The Simplenote synchronization method appears to not work. Another method is synchronizing to a folder in Dropbox and editing them on the iPad using the Notebooks app. That method does work, so I do have an alternative to the Simplenote approach.

I have also posted a query on the Simplenote support forum.

Yeah, in general using folder sync is much more reliable, we’ve found. Simplenote has been plagued by issues over the past year. For a while it wasn’t even saving mobile work at all and people were losing work when they came home and expected to see iPad changes show up—they never did because the server never registered them off of the device. We’re probably going to remove it in future versions of Scrivener for this reason (well, and by that point we hope to have the iOS version of Scrivener, making the need for this particular tool negligible at best). It’s just been nothing but a hassle. So I would encourage familiarising yourself with the folder sync method and combining that with whatever synchronisation service and compliant text editors you prefer.

It would be nice to figure out what is going on with the server error though. According to what I’ve discovered on the 'net, a 401 error means you do not have authorisation to carry out the requested commands. Perhaps resetting your password might jar things loose?