Simplest/Best way to set up folders & texts for novel

10,000 words into my MS I’m confused by the way folders and text documents should be structured and displayed in my Binder. I always just assumed that in order to separate scenes in my draft I HAD to use the Split function. So, when I went back to rewrite some things within the two scenes of my first chapter I messed things up and got “three Chapter 1s” with different content in each! (please see attachment).

I would like simply to structure my novel in one of the ways mentioned by KB some time ago: “Chapter folders containing text documents acting as scenes.”

Referring to the attached screen shot of my Binder, my questions are:

  1. Why does my “first Chapter 1” contain only my first scene; the “second Chapter 1” contain NOTHING; and the third “Chapter 1” contain my second scene?

  2. Closely related, why do the folder icons in all my “Chapter 1s” show that there’s text inside of them when ONE of them contains nothing?

  3. Why does my Chapter 2 folder icon CORRECTLY show text inside of it, yet my Chapters 3,4 and 5 –- which ALSO have text inside – do NOT display the “text inside” icon?

I’m confused. I guess I missed something along the way. I would sincerely appreciate someone setting me straight on this. Thanks a million!
Screen shot 2015-10-22 at 12.40.15 PM.png

Let’s start by defining two different ways that a folder can ‘have text inside it’. The first way is to have a document indented under it, the way that levels of a traditional outline are indented (I. topic, A. Sub-topic, B. Sub-topic, 1. sub-sub-topic, etc…) . We’ll say that the folder “contains text documents” in that instance, the same way that a physical manila file folder could contain a few staple-bound paper documents (a.k.a. scene documents).

Your chapter 3, 4, and 5 folders contain text documents in this manner.

Then there’s the situation where you can treat a folder as if it were a text document. In this version of the analogy, you have taken a pen and written all over the surface of the folder itself. This is what you’ve (apparently) done with your various Chapter 1 folders. Note that even a blank line or a single space counts. To see these invisible characters, go to Format->Options->Show Invisibles.

Chapter 2 shows you have written on the folder AND ALSO put staple-bound scene documents in the folder, to complete the metaphor.

Hopefully, that begins to make some sense. To begin fixing the inconsistencies here, I suggest you start with the chapter 1 folders. Select all of the (CTRL-Click on each one), and then at the bottom of the inspector, click the gear icon and choose Convert to File. That will change their icons, but won’t do anything to the text or other information attached to the former folders. Now view each one. If any of them are empty and you don’t have any reason to save that former folder, then just send that one to the trash. Rename the rest in the way you have the other scene documents, as you did in Chapter 3. Now go back to the binder and CTRL-click the documents that make up chapter 1 and select the menu item Documents->Group. Name the new folder that appears Chapter 1; it will contain the files you had selected previously.

Chapter 2 is a little tricky. Try clicking on it, and the on the icon in the toolbar that shows 3 tiny icons in a row (from left to right, paper/stack of papers, cork board, and outline). Click on the paper/stack of papers icon once or twice so that you only see one document when you scroll through it. If there is text written ‘on’ the folder, you should either create a new empty document to put above the other documents in chapter two and cut and paste the text into the new document, or you may just find a few stray ‘invisible’ characters there that you can delete.

I hope that wasn’t too confusing. The fact that folders and files can transform into one another, and that both of them can be ‘written on’ is a little odd, but can be useful sometimes, if you get deeper into the compile settings (adding a differently-formatted quote or poem to the beginning of each chapter, for instance). But let’s save that for another topic.

Good luck!

It also looks like the OP has scriptwriting mode turned on for the first doc in Chapter 5. Probably not intended.

Thank you, rdale. You have a knack for explaining things simply and clearly. This isn’t the first time you’ve helped me understand some things that were blowing my mind, and I appreciate your taking the time to help this old codger.

One quick follow-up: I can’t remember (nor find a reason) for dog-eared text docs that appear in a couple of my chapters. And, as gr points out:

I don’t have scriptwriting mode turned on there. So I’m wondering why that particular text doc appears slightly different.

Thanks again to both of you!

  1. The dog-ear on a doc icon indicates something independently of what has been said so far. It indicates that the Snapshot function has been used on that page – which means that Scrivener has squirreled away an earlier version of that particular document. See Snapshots in the manual, if needed. (If taken inadvertently, no need to take any action. You can safely ignore it.)

  2. Scriptwriting mode is on or off on a per document basis. So, to see if scriptwriting mode is on for that doc, you need to select it in the binder and either i) look at the Script item on the toolbar to see if it has a green checkmark, or look at the menu list Formatting > Scriptwriting to see if the Scriptmode item is checked. If either of these are the case, that document is set for scriptwriting mode. Otherwise not.

Best,
Greg

P.S. I note that scriptwriting mode and snapshotting both have similar key commands (cmd 8 and cmd 5, respectively). It is possible that you inadvertently switched modes and/or snapshotted while you were trying for some other command.

  1. Thanks for the explanation, GR. I had forgotten all about the snapshots I had taken some time ago. I haven’t used that function in the last several months.

  2. And it turns out I did have the script writing mode turned on. You have a sharp eye, and I appreciate your response!