sluggish performance when autosaves

I have problem which has already been mentioned - Scrivener has become very sluggish and when autosaves, it stops for several seconds while the circle is turning on screen. I’ve noticed that some people were able to change the autosave periods which solved the problem - but I could not find how to do it! Could you please help, as it has become impossibly annoying to work.
Thank you!
(1.67 GHz Mac
10.4.9
2 GB Ram
project size 19.6 MB)

Yes, with big projects this will become an issue. Actually, it depends less on the size of the .scriv file, and more on the size of the .scrivproj file that is contained inside the .scriv file, meaning that you could have a massive project that saved more quickly than a smaller one… But that is by the by. To change the auto-save period, just go to Preferences and you will see a text field in which to enter the auto-save delay in the General pane. By default it is set to 2 seconds - you might want to change it to something like 300 seconds for a 5 minute delay. If you do this, do make sure you save manually on a regular basis!

(If you can’t see the setting in Preferences, make sure you have the most recent update by going to Scrivener > Check for Updates…), as this feature was only introduced in 1.02.)

All the best,
Keith

Many thanks, Keith. I’ve updated the software and changed autosave to 120 seconds, but it still has the same problem, which is very apparent when I do highlighting - the wheel appears and everything stops for a few seconds, even though autosave is not engaged.
I’ve trushed Cache and rebooted th compuer but it has not solved the problem.
My binder.scrivproj file is only 32 K
My BinderStrings.xml is 4.8 MB

binderStrings.xml also gets saved during a save operation, but if you have set autosave to 120 seconds then it shouldn’t be an issue. When you get the slowdown, is the red dot in the top-left corner of the window “dirtied” (i.e. does it have a darker dot inside it to indicate that the document has changed)? And once the beachball stops, has the dot disappeared? This indicates that the slowdown is caused by a save.

However, it may be that you have a different issue. Are you in full screen or normal mode? Do you have any other programs operating in the background, or anything installed on your system that hacks into the text system? It may be something else entirely.

Best,
Keith