Smart quotes deleted when I Copy Special...

I type using ‘smart quotes’ and frequently I type for forums that use BBCode, so I make use of the ‘Copy Special > As BBCode’ option to copy text from Scrivener. If I Copy Special, however, smart quotes are left behind and pasted text has no quotes at all.

For example, if I apply formatting to this text:
“Don’t think that you’re special, girl.”

If I copy as BBCode, I get this:
“Don’t think that you’re special, [i]girl.”[/i]

If I uncheck the ‘use smart quotes’ option, though, it does fine.
"Don’t think that you’re special, [i]girl."[/i]

I don’t mind not using smart quotes for now, but it seemed like a bug that I should report.