Smart quotes problem when changing computer


I’m using Scrivener for two different projects and on two computers. Desktop is running Windows 7, laptop Mac OS X. Most of the times, I end up working on working on my novel on the laptop, and on the PC I mostly work on my PhD thesis, that’s my two main Scrivener projects and I never opened them on the other computer until now. They each had a dedicated computer (novel->laptop, thesis->desktop PC). But I need to get more mobile on my thesis writing so I’m trying to go cross-platform with this project file. I’m a little bit scared, but I’ve read all the information and I back-up everything correctly on all sides so there is not much to worry about. I’m syncing with Dropbox (always being very careful—read: paranoid—about letting it fully sync) to go from one computer to the other.

I had no problem until now, but today when I opened my thesis project on Mac all the French smart quotes that were in my text files (’«’ and ‘»’) were changed to English curly quotes (’“’ and ‘”’). I was a little worried because, as you can guess, there can be a lot of quotes in a thesis. And since I also use the English curly quotes for text quoted inside a quote, I can’t just replace them all at once. I verified: ‘Use smart quotes’ is checked in the Preferences menu. On both computers that is. In the Windows version, I can manually choose which kind of smart quotes I want (French or the curly ones, etc.) but not in the Mac version. (Which, I guess, is because this function is linked to the system Text Preferences or something?) Well, all that to say that I closed my project right away, sync’ed and went back to the PC to see if everything was OK. I was relieved to see that all my French smart quotes were back in my Scrivener project when I opened it back on Windows. So all is good.

But still, I can’t seem to find a solution to get my project correctly displayed in the Mac version. Any idea what could cause this and what I can do this fix it?

Thanks in advance for any help.


Could it be the font you are using on the mac does not have the guillemets and reverts to the " by default?

I’m afraid not: I’m using Georgia on both computers.

Yes, but the two implementations of the font may be different. Just to be sure, I’d double check to verify that you can create the quotes natively on the Mac, say in TextEdit.


I can create the quotes natively on Mac, I do it all the time. Here’s for the show: «I’m a quote.» :wink: (And for my other project, the one I only open on my MacBook Pro, I use smart quotes constantly and I always get the desired French ones.)

So, no, I just double-checked, that really doesn’t seem the problem. I tried multiple fonts and the smart quotes always appear as the English curly ones (instead of the French ‘«’ and ‘»’). And when I go back to the PC they appear correctly.

And what puzzles me is that about two weeks ago I first opened this project (thesis) on my MacBook Pro and the smart quotes appeared correctly (’«’ and ‘»’), as they are supposed to. I have no memory of having changed anything that could trigger this. I only wrote text in my project without ever changing the fonts…

I really need to get this working—any help appreciated. Thanks in advance.

EDIT: Oh, and by the way, I can create the desired quotes in this project on Mac too. So the smart quotes do work. The problem is: all French the smart quotes written on Windows appears as English smart quotes when I open a project on Mac. And it is not a “conversion”: I mean, as I said, when I open the project file back on Windows all the French smart quotes are back…

Noooooooooo! I was too fast with the ‘edit’ of my last post: after I tried adding smart quotes on Mac—which appeared, I repeat, as the correct French quotes on Mac—I went back on Windows and this time it had a devastating effect: all my French smart quotes were converted to English ones:frowning:

EDIT: OK, less disastrous than I thought: it only converted the quotes in one document…
2ND EDIT: Errr, I didn’t even touch the file—only thing I did in Scrivener since my last post was try to open a back-up file and close it—and a couple of hours later, I open my project file and the correct quotes are back in my file… I have no idea what is going on here?.. (And sorry if this is getting a bit confusing.)

OK. I’m still really looking for a solution to this problem. Anyone knows what is going on? :frowning:

First post is still a correct description of the problem.

Sorry for bumping this again, but I’m still looking for help or any kind of information that would lead to fixing the problem.

First post is still accurate.

Since “smart” quotes are set up universally on the Mac, have you checked the “Text” tab in the Keyboard system preference pane? That is where they will be set up. I would not have thought that this would ever impact existing glyphs in a document, however, just what happens when you type.

Yes, I did check that. Everything is fine there: French is the set language, and the smart quotes are the ones I need (’«’ and ‘»’).

And this is not the problem: I have no problem typing the desired smart quotes in the Mac version of Scrivener. The smart quotes choice behave correctly. The problem is in the smart quotes typed under Windows. They appear correctly under Windows. I sync, check my project on Mac and all the French smart quotes gets converted to English curly quotes.

Luckily, I can still work in the Mac version and when I sync back in Windows, most of the time the French smart quotes are back. I say most of the time, because one of my file seems to have been permanently converted to English smart quotes. But just one file in my whole project. No idea why.

This is all rather confusing and I can’t quite understand what is going on.

Any help appreciated.

EDIT: Removed this paragraph, as I can report it is not accurate after further testing: “Even the French smart quotes that I typed, for example, under Mac, that still appears correct (still French quotes) when I go back to Windows, will appear as English curly quotes when I get back on the Mac.” French smarth quotes typed (yesterday) on Mac, that appear as French smart quotes on PC, still appear as French smart quotes when I went back on the Mac just now. But it all seems so random… French smart quotes typed on the Mac about a month ago appear as English smart quotes on Mac. And everything still appears correctly on PC. Always just a display issue, not a conversion except for that one file I’ve already talked about. I really would like to be able to give you systematic information but it really all seems so random…

Hmm. What happens if you create smart quotes in something like Word or WordPad under Windows, and then transfer that file to the Mac? I’m wondering if this is a Windows issue, rather than something specific to Scrivener.


They appear correctly. I just tested it with a fresh .doc file created in Word 2010 under Windows and then opened in Word 2011 under Mac OS X. French smart quotes created on PC appears in Word as correct French smart quotes on Mac.

Frankly, I find this all rather puzzling.

What if you import that same Windows-based Word file into Scrivener on the Mac?


The imported file shows correct French smart quotes in Scrivener (Mac).

I also just tested something else, just in case. I have Scrivener set in English for the menus, etc., but everything text-related (spell checking, substitutions, etc.) is set for French text. I tried changing Scrivener itself on Windows to French in case there was some kind of conflict. I open my project back on Mac: no change, all French smart quotes still appear as English ones. So no change except that the EDIT I made two posts up (about the smart quotes created on Mac staying French smart quotes even after a sync on PC) is not true anymore. Back on the Mac, these smart quotes were changed to English smart quotes after I changed the language setting (for the software, not for the text that is).

Everything still appear correctly back on Windows.

I just noticed that you said you are running Windows 7, but not which version of OS X you have. Which is it, please?


Mac OS X 10.6.8.

Thanks for trying to help me solve this problem. It is appreciated.

The trouble appears to be that the quotes are being encoded differently on the Mac and on Scrivener for Windows. I need to check up on this a bit more though to figure out what might work as a solution, but that at least seems the basis of the problem.

There is no hurry—I should survive until there is a fix. :slight_smile: Just to hear that there could be a solution to this problem someday makes me very happy. I was afraid that it would drive me crazy before I could reach the end of my PhD thesis.

Thanks again, MimeticMouton—your posts always bring good news for my Scrivener & Scapple problems!

We’re now three months later and I was wondering if there was any news regarding this problem? It’s still happening all the time for me, whenever I open my project under Mac and come back on Windows. It’s not dramatic, but it’s still quite annoying.

Thanks again for the good work!