smart quotes stop working

I have ‘smart quotes’ selected in Substitutions, and when I open Scrivener and start a work session the smart quotes work just fine to start with. But after a while–today, about an hour–they stop working and Scrivener reverts to straight quotes. The only method that seems to fix this problem is quitting and reopening Scrivener Is there an easier way of keeping the smart quotes working?

Unfortunately that’s a known issue that to date we have not been able to reproduce well enough to fix (and furthermore seems to be in the text engine itself, which is largely out of our control).

Ah, that’s a real shame. I’ve had this problem for years; it used to be intermittent but it is becoming a consistent problem, hence my enquiry. I sincerely hope it doesn’t deteriorate further as it might eventually become a dealbreaker.

I don’t know what ‘in the text engine’ means–not that it matters.

Thanks anyway.
PS I’m sorry if you’ve answered this question a zillion times already. I did search in the forums but nothing relevant appeared.

Yeah, it’s an odd one in that people have seen it come and go over the years. They’ll have a period of time where it happens after a few hours of editing in a consistent fashion, and then after a macOS update it goes away for a year or two entirely. It has been around since at least 10.8 if I recall correctly. If you do happen across a preference or setting that seems to make a difference, we’d love to hear about it. At the very least if we could get it to happen reliably on our end, it would be a lot easier to track down.

As for the text engine, it’s the part of the Mac we use to provide a text editor for you to type into. You can see the same editor in the free TextEdit program that ships with the Mac, for example. Once you look at the similarities between TextEdit and Scrivener, at least at the formatting level, you can see how much technology we are depending upon for that! It’s very difficult to fix problems that originate in that scope.

That’s very helpful. Thank you. And if I ever do find something that fixes it I will contact you as soon as I finish my happy dance.

Two options that might save from the deal from breaking.

  1. Load the manuscript in scrivenings and then choose:
    Edit > Transformations > Convert Quotes to Smart Quotes

  2. Actually type the smart quotation marks you need:

Left single quotation mark ‘ => OPT ]

Right single quotation mark (and apostrophe) ’ => OPT SHIFT ]

Left double quotation mark “ => OPT [

Right double quotation mark ” => OPT SHIFT [

Slàinte mhòr.

Thank you!